diff options
author | zhengruoqin <zhengrq.fnst@fujitsu.com> | 2022-09-27 17:37:13 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-09-28 14:54:31 -0700 |
commit | 8d24a879eb6e510ddc10a844092fab3eccfec8bc (patch) | |
tree | 6021f2ce03e4b92efde43c60a9f824229036827c /meta-python/recipes-devtools/python/python3-sqlparse_0.4.3.bb | |
parent | d52f4d62e11e13ed558ca33600a82dd1d5625e62 (diff) | |
download | meta-openembedded-8d24a879eb6e510ddc10a844092fab3eccfec8bc.tar.gz |
python3-sqlparse: upgrade 0.4.2 -> 0.4.3
Changelog:
==========
Enhancements
-------------
Add support for DIV operator
Add support for additional SPARK keywords
Avoid tokens copy
Add REGEXP as a comparision
Add DISTINCTROW keyword for MS Access (issue677).
Improve parsing of CREATE TABLE AS SELECT
Bug Fixes
---------
Fix spelling of INDICATOR keyword
Fix formatting error in EXTRACT function
Fix bad parsing of create table statements that use lower case
Handle backtick as valid quote char
Allow any unicode character as valid identifier name (issue641).
Other
-------
Update github actions to test on Python 3.10 as well
Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sqlparse_0.4.3.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-sqlparse_0.4.3.bb | 28 |
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sqlparse_0.4.3.bb b/meta-python/recipes-devtools/python/python3-sqlparse_0.4.3.bb new file mode 100644 index 000000000..c952c71d0 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-sqlparse_0.4.3.bb | |||
@@ -0,0 +1,28 @@ | |||
1 | DESCRIPTION = "Non-validating SQL parser module" | ||
2 | HOMEPAGE = "http://pypi.python.org/pypi/sqlparse" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "BSD-3-Clause" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2b136f573f5386001ea3b7b9016222fc" | ||
6 | |||
7 | SRC_URI += "file://0001-sqlparse-change-shebang-to-python3.patch \ | ||
8 | file://run-ptest \ | ||
9 | " | ||
10 | |||
11 | SRC_URI[sha256sum] = "69ca804846bb114d2ec380e4360a8a340db83f0ccf3afceeb1404df028f57268" | ||
12 | |||
13 | export BUILD_SYS | ||
14 | export HOST_SYS | ||
15 | |||
16 | inherit pypi ptest setuptools3 | ||
17 | |||
18 | RDEPENDS:${PN}-ptest += " \ | ||
19 | ${PYTHON_PN}-pytest \ | ||
20 | ${PYTHON_PN}-unixadmin \ | ||
21 | " | ||
22 | |||
23 | do_install_ptest() { | ||
24 | install -d ${D}${PTEST_PATH}/tests | ||
25 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
26 | } | ||
27 | |||
28 | BBCLASSEXTEND = "native nativesdk" | ||