diff options
author | zhengruoqin <zhengrq.fnst@fujitsu.com> | 2021-07-26 18:48:19 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-07-29 10:35:05 -0700 |
commit | 492054e40931d4d924bcc58b87688e81310ea4cd (patch) | |
tree | 03dad26fbdd1d06aa32096ad4176ed4928bcbcd5 /meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.22.bb | |
parent | e6b3dcb6b8e47ca9fd5c7f28e7cb88d136b7d1a6 (diff) | |
download | meta-openembedded-492054e40931d4d924bcc58b87688e81310ea4cd.tar.gz |
python3-sqlalchemy: upgrade 1.4.20 -> 1.4.22
.. changelog::
:version: 1.4.22
:released: July 21, 2021
.. change::
:tags: bug, sql
:tickets: 6786
Fixed issue where use of the :paramref:`_sql.case.whens` parameter passing
a dictionary positionally and not as a keyword argument would emit a 2.0
deprecation warning, referring to the deprecation of passing a list
positionally. The dictionary format of "whens", passed positionally, is
still supported and was accidentally marked as deprecated.
.. change::
:tags: bug, orm
:tickets: 6775
Fixed issue in new :meth:`_schema.Table.table_valued` method where the
resulting :class:`_sql.TableValuedColumn` construct would not respond
correctly to alias adaptation as is used throughout the ORM, such as for
eager loading, polymorphic loading, etc.
.. change::
:tags: bug, orm
:tickets: 6769
Fixed issue where usage of the :meth:`_result.Result.unique` method with an
ORM result that included column expressions with unhashable types, such as
``JSON`` or ``ARRAY`` using non-tuples would silently fall back to using
the ``id()`` function, rather than raising an error. This now raises an
error when the :meth:`_result.Result.unique` method is used in a 2.0 style
ORM query. Additionally, hashability is assumed to be True for result
values of unknown type, such as often happens when using SQL functions of
unknown return type; if values are truly not hashable then the ``hash()``
itself will raise.
For legacy ORM queries, since the legacy :class:`_orm.Query` object
uniquifies in all cases, the old rules remain in place, which is to use
``id()`` for result values of unknown type as this legacy uniquing is
mostly for the purpose of uniquing ORM entities and not column values.
.. change::
:tags: orm, bug
:tickets: 6771
Fixed an issue where clearing of mappers during things like test suite
teardowns could cause a "dictionary changed size" warning during garbage
collection, due to iteration of a weak-referencing dictionary. A ``list()``
has been applied to prevent concurrent GC from affecting this operation.
.. change::
:tags: bug, sql
:tickets: 6770
Fixed issue where type-specific bound parameter handlers would not be
called upon in the case of using the :meth:`_sql.Insert.values` method with
the Python ``None`` value; in particular, this would be noticed when using
the :class:`_types.JSON` datatype as well as related PostgreSQL specific
types such as :class:`_postgresql.JSONB` which would fail to encode the
Python ``None`` value into JSON null, however the issue was generalized to
any bound parameter handler in conjunction with this specific method of
:class:`_sql.Insert`.
.. change::
:tags: bug, engine
:tickets: 6740
Added some guards against ``KeyError`` in the event system to accommodate
the case that the interpreter is shutting down at the same time
:meth:`_engine.Engine.dispose` is being called, which would cause stack
trace warnings.
.. change::
:tags: bug, orm, regression
:tickets: 6793
Fixed critical caching issue where the ORM's persistence feature using
INSERT..RETURNING would cache an incorrect query when mixing the "bulk
save" and standard "flush" forms of INSERT.
Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.22.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.22.bb | 21 |
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.22.bb b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.22.bb new file mode 100644 index 000000000..feb509e3f --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.22.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \ | ||
2 | application developers the full power and flexibility of SQL" | ||
3 | HOMEPAGE = "http://www.sqlalchemy.org/" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3359ed561ac16aaa25b6c6eff84df595" | ||
6 | |||
7 | SRC_URI[sha256sum] = "ec1be26cdccd60d180359a527d5980d959a26269a2c7b1b327a1eea0cab37ed8" | ||
8 | |||
9 | PYPI_PACKAGE = "SQLAlchemy" | ||
10 | inherit pypi setuptools3 | ||
11 | |||
12 | RDEPENDS_${PN} += " \ | ||
13 | ${PYTHON_PN}-json \ | ||
14 | ${PYTHON_PN}-pickle \ | ||
15 | ${PYTHON_PN}-logging \ | ||
16 | ${PYTHON_PN}-netclient \ | ||
17 | ${PYTHON_PN}-numbers \ | ||
18 | ${PYTHON_PN}-threading \ | ||
19 | ${PYTHON_PN}-compression \ | ||
20 | ${PYTHON_PN}-profile \ | ||
21 | " | ||