diff options
author | Wang Mingyu <wangmy@fujitsu.com> | 2024-04-17 09:40:48 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-04-17 23:47:27 -0700 |
commit | 370ac7784b43027b42f68e3a641d6df322a927c8 (patch) | |
tree | 674a8d0fd73a1d1489917dd1e8908c296c8ac84d /meta-python/recipes-devtools/python/python3-sentry-sdk_1.45.0.bb | |
parent | 33cd26f80329f7762ffbbf59a705d7714cd5f278 (diff) | |
download | meta-openembedded-370ac7784b43027b42f68e3a641d6df322a927c8.tar.gz |
python3-sentry-sdk: upgrade 1.44.0 -> 1.45.0
Changelog:
==========
-Allow to upsert monitors
-Add Django signals_denylist to filter signals that are attached to by signals_spans
-increment for metrics
-Add value, unit to before_emit_metric
-Remove experimental metric summary options
-New normalization rules for metric keys, names, units, tags
-Change data_category from statsd to metric_bucket
-Accessing __mro__ might throw a ValueError
-Suppress prompt spawned by subprocess when using pythonw
-Handle None in GraphQL query
-Do not send "quiet" Sanic exceptions to Sentry
-Implement metric_bucket rate limits
-Fix type hints for monitor decorator
-Remove deprecated typing imports in crons
-Make monitor_config a TypedDict
-Add devenv-requirements.txt and update env setup instructions
-Bump types-protobuf from 4.24.0.20240311 to 4.24.0.20240408
-Disable Codecov check run annotations
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sentry-sdk_1.45.0.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-sentry-sdk_1.45.0.bb | 22 |
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sentry-sdk_1.45.0.bb b/meta-python/recipes-devtools/python/python3-sentry-sdk_1.45.0.bb new file mode 100644 index 000000000..c3e53b518 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-sentry-sdk_1.45.0.bb | |||
@@ -0,0 +1,22 @@ | |||
1 | SUMMARY = "The new Python SDK for Sentry.io" | ||
2 | DESCRIPTION = "This is the next line of the Python SDK \ | ||
3 | for Sentry, intended to replace the raven package on PyPI." | ||
4 | HOMEPAGE = "https://github.com/getsentry/sentry-python" | ||
5 | LICENSE = "MIT" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=03dc788d9a9486be5e6a1d99c2c1ce3a" | ||
7 | |||
8 | RDEPENDS:${PN} += "\ | ||
9 | python3-urllib3 \ | ||
10 | python3-core \ | ||
11 | python3-json \ | ||
12 | python3-logging \ | ||
13 | python3-threading \ | ||
14 | python3-compression \ | ||
15 | python3-datetime \ | ||
16 | " | ||
17 | |||
18 | SRC_URI[sha256sum] = "509aa9678c0512344ca886281766c2e538682f8acfa50fd8d405f8c417ad0625" | ||
19 | |||
20 | PYPI_PACKAGE = "sentry-sdk" | ||
21 | |||
22 | inherit pypi setuptools3 | ||