summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-robotframework_4.0.3.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-05-27 00:34:10 +0300
committerKhem Raj <raj.khem@gmail.com>2021-05-28 06:50:20 -0700
commitaed4b12ba01aa2dd57612143ba50b42e8c6a3910 (patch)
tree1126e150acdd7cd9dd99af0f88552fe1575f636c /meta-python/recipes-devtools/python/python3-robotframework_4.0.3.bb
parentbaa8a5e3c8a93e84e416981121124c2971ac9d90 (diff)
downloadmeta-openembedded-aed4b12ba01aa2dd57612143ba50b42e8c6a3910.tar.gz
python3-robotframework: Upgrade 4.0.2 -> 4.0.3
Upgrade to release 4.0.3: - Regression using TypedDict as type hint Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-robotframework_4.0.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-robotframework_4.0.3.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-robotframework_4.0.3.bb b/meta-python/recipes-devtools/python/python3-robotframework_4.0.3.bb
new file mode 100644
index 000000000..d95ab109a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-robotframework_4.0.3.bb
@@ -0,0 +1,27 @@
1SUMMARY = "A Python generic test automation framework"
2DESCRIPTION = "Generic open source test atomation framework for acceptance\
3testing and acceptance test-driven development (ATDD). It has easy-to-use\
4tabular test data syntax and it utilizes the keyword-driven testing approach.\
5Its testing capabilities can be extended by test libraries implemented either\
6with Python or Java, and users can create new higher-level keywords from\
7existing ones using the same syntax that is used for creating test cases."
8HOMEPAGE = "http://robotframework.org"
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
11
12inherit pypi setuptools3
13
14PYPI_PACKAGE_EXT = "zip"
15
16SRC_URI[sha256sum] = "93c2107f789fd897f234f4b8f1ba8e7b9f4ef326d9bcbfceb71dda8cc197388c"
17
18RDEPENDS_${PN} += " \
19 ${PYTHON_PN}-shell \
20 ${PYTHON_PN}-pprint \
21 ${PYTHON_PN}-xml \
22 ${PYTHON_PN}-difflib \
23 ${PYTHON_PN}-threading \
24 ${PYTHON_PN}-html \
25 ${PYTHON_PN}-docutils \
26 ${PYTHON_PN}-ctypes \
27"