summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-robotframework_3.0.4.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-04 13:29:06 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 10:38:13 -0700
commit5e2720f901391c0e5905bd79864e7bf47e62778a (patch)
treec25fe490610bb02ce724e149272f7bc2f50d3649 /meta-python/recipes-devtools/python/python3-robotframework_3.0.4.bb
parent532225c0119420ca1ea0a4e49de1db239ab2210b (diff)
downloadmeta-openembedded-5e2720f901391c0e5905bd79864e7bf47e62778a.tar.gz
python-robotframework: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-robotframework_3.0.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-robotframework_3.0.4.bb28
1 files changed, 26 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-robotframework_3.0.4.bb b/meta-python/recipes-devtools/python/python3-robotframework_3.0.4.bb
index 8f613c386..0628f92d9 100644
--- a/meta-python/recipes-devtools/python/python3-robotframework_3.0.4.bb
+++ b/meta-python/recipes-devtools/python/python3-robotframework_3.0.4.bb
@@ -1,2 +1,26 @@
1inherit setuptools3 1SUMMARY = "A Python generic test automation framework"
2require python-robotframework.inc 2DESCRIPTION = "Generic open source test atomation framework for acceptance\
3testing and acceptance test-driven development (ATDD). It has easy-to-use\
4tabular test data syntax and it utilizes the keyword-driven testing approach.\
5Its testing capabilities can be extended by test libraries implemented either\
6with Python or Java, and users can create new higher-level keywords from\
7existing ones using the same syntax that is used for creating test cases."
8HOMEPAGE = "http://robotframework.org"
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
11
12inherit pypi setuptools3
13
14SRC_URI[md5sum] = "ee753415645ff4831ff0d366a0467fe7"
15SRC_URI[sha256sum] = "ab94257cbd848dfca7148e092d233a12853cc7e840ce8231af9cbb5e7f51aa47"
16
17RDEPENDS_${PN} += " \
18 ${PYTHON_PN}-shell \
19 ${PYTHON_PN}-pprint \
20 ${PYTHON_PN}-xml \
21 ${PYTHON_PN}-difflib \
22 ${PYTHON_PN}-threading \
23 ${PYTHON_PN}-html \
24 ${PYTHON_PN}-docutils \
25 ${PYTHON_PN}-ctypes \
26"