diff options
author | Sakib Sajal <sakib.sajal@windriver.com> | 2020-07-10 14:15:55 -0400 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-07-12 19:04:17 -0700 |
commit | ed2e3e44fd3bb739d30583ee968232dccf0a1217 (patch) | |
tree | eb48bb815aec0fd4ab4c9f6aa83e8c71d91c6a9b /meta-python/recipes-devtools/python/python3-requests-toolbelt_0.9.1.bb | |
parent | 0e38dbd16625773bbde31a049fedbb30b89f0ffa (diff) | |
download | meta-openembedded-ed2e3e44fd3bb739d30583ee968232dccf0a1217.tar.gz |
python3-requests-toolbelt: add ptest
Signed-off-by: Sakib Sajal <sakib.sajal@windriver.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-requests-toolbelt_0.9.1.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-requests-toolbelt_0.9.1.bb | 22 |
1 files changed, 20 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-requests-toolbelt_0.9.1.bb b/meta-python/recipes-devtools/python/python3-requests-toolbelt_0.9.1.bb index 3beb39718..cb1bc607b 100644 --- a/meta-python/recipes-devtools/python/python3-requests-toolbelt_0.9.1.bb +++ b/meta-python/recipes-devtools/python/python3-requests-toolbelt_0.9.1.bb | |||
@@ -5,12 +5,30 @@ AUTHOR = "Ian Cordasco, Cory Benfield" | |||
5 | LICENSE = "Apache-2.0" | 5 | LICENSE = "Apache-2.0" |
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=71760e0f1dda8cff91b0bc9246caf571" | 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=71760e0f1dda8cff91b0bc9246caf571" |
7 | 7 | ||
8 | SRC_URI = "file://run-ptest \ | ||
9 | " | ||
10 | |||
8 | SRC_URI[md5sum] = "b1509735c4b4cf95df2619facbc3672e" | 11 | SRC_URI[md5sum] = "b1509735c4b4cf95df2619facbc3672e" |
9 | SRC_URI[sha256sum] = "968089d4584ad4ad7c171454f0a5c6dac23971e9472521ea3b6d49d610aa6fc0" | 12 | SRC_URI[sha256sum] = "968089d4584ad4ad7c171454f0a5c6dac23971e9472521ea3b6d49d610aa6fc0" |
10 | 13 | ||
11 | inherit setuptools3 | 14 | inherit pypi setuptools3 ptest |
12 | inherit pypi | ||
13 | 15 | ||
14 | RDEPENDS_${PN} += " \ | 16 | RDEPENDS_${PN} += " \ |
15 | ${PYTHON_PN}-requests (>=2.0.1) \ | 17 | ${PYTHON_PN}-requests (>=2.0.1) \ |
16 | " | 18 | " |
19 | |||
20 | RDEPENDS_${PN}-ptest += " \ | ||
21 | ${PYTHON_PN}-pytest \ | ||
22 | ${PYTHON_PN}-betamax \ | ||
23 | ${PYTHON_PN}-mock \ | ||
24 | ${PYTHON_PN}-multiprocessing \ | ||
25 | " | ||
26 | |||
27 | do_install_ptest() { | ||
28 | install -d ${D}${PTEST_PATH}/tests | ||
29 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
30 | cp -rf ${S}/setup.py ${D}${PTEST_PATH} | ||
31 | # remove test test_multipart_encoder.py as it fails, | ||
32 | # downloaded file is not supported | ||
33 | rm -f ${D}${PTEST_PATH}/tests/test_multipart_encoder.py | ||
34 | } | ||