summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-requests-toolbelt_0.10.1.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2022-11-01 10:08:00 +0800
committerKhem Raj <raj.khem@gmail.com>2022-11-07 08:39:05 -0800
commitb5cd6f6164eb3ab0403f610236ac0cbbe5459671 (patch)
treef5aa8c1c63179e27d96a8c5a5e4fbf60582bfa42 /meta-python/recipes-devtools/python/python3-requests-toolbelt_0.10.1.bb
parent30666bb8356bc80caab67f563ef936a7b014f8be (diff)
downloadmeta-openembedded-b5cd6f6164eb3ab0403f610236ac0cbbe5459671.tar.gz
python3-requests-toolbelt: upgrade 0.10.0 -> 0.10.1
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-requests-toolbelt_0.10.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-requests-toolbelt_0.10.1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-requests-toolbelt_0.10.1.bb b/meta-python/recipes-devtools/python/python3-requests-toolbelt_0.10.1.bb
new file mode 100644
index 000000000..b2678952c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-requests-toolbelt_0.10.1.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "A utility belt for advanced users of python-requests."
2HOMEPAGE = "https://toolbelt.readthedocs.org"
3AUTHOR = "Ian Cordasco, Cory Benfield"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=6f14302a4b4099009ab38b4dde5f1075"
7
8SRC_URI = "file://run-ptest \
9 "
10
11SRC_URI[sha256sum] = "62e09f7ff5ccbda92772a29f394a49c3ad6cb181d568b1337626b2abb628a63d"
12
13inherit pypi setuptools3 ptest
14
15RDEPENDS:${PN} += " \
16 ${PYTHON_PN}-requests (>=2.0.1) \
17"
18
19RDEPENDS:${PN}-ptest += " \
20 ${PYTHON_PN}-pytest \
21 ${PYTHON_PN}-betamax \
22 ${PYTHON_PN}-mock \
23 ${PYTHON_PN}-multiprocessing \
24"
25
26do_install_ptest() {
27 install -d ${D}${PTEST_PATH}/tests
28 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
29 cp -rf ${S}/setup.py ${D}${PTEST_PATH}
30 # remove test test_multipart_encoder.py as it fails,
31 # downloaded file is not supported
32 rm -f ${D}${PTEST_PATH}/tests/test_multipart_encoder.py
33}