summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-rdflib_6.1.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2022-01-10 21:38:14 +0200
committerKhem Raj <raj.khem@gmail.com>2022-01-11 17:50:55 -0800
commitf8d3f2de49cfdf76956e01553d9682215d4e7508 (patch)
treed421f5a7ee695f82d6b46635fa515e7dc4883948 /meta-python/recipes-devtools/python/python3-rdflib_6.1.1.bb
parent30a76214897a497121f8dc156ff66bc31cda627d (diff)
downloadmeta-openembedded-f8d3f2de49cfdf76956e01553d9682215d4e7508.tar.gz
python3-rdflib: Upgrade 6.0.2 -> 6.1.1
Upgrade to release 6.1.1: - add support for Python 3.10 - updates the test suite to pytest (from nose) - tidies up a lot of continuous integration - gets more tests tested, not skipped - implements lots of mypy tests - updates several parsers and serializers - supports the new HexTuples format! - many bug fixes Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-rdflib_6.1.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-rdflib_6.1.1.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-rdflib_6.1.1.bb b/meta-python/recipes-devtools/python/python3-rdflib_6.1.1.bb
new file mode 100644
index 000000000..27f65dced
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-rdflib_6.1.1.bb
@@ -0,0 +1,17 @@
1SUMMARY = "RDFLib is a pure Python package for working with RDF"
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=b6cde159c801514e0e45a40cf0a9d3d9"
4
5SRC_URI[sha256sum] = "8dbfa0af2990b98471dacbc936d6494c997ede92fd8ed693fb84ee700ef6f754"
6
7inherit pypi setuptools3
8
9RDEPENDS:${PN} += " \
10 ${PYTHON_PN}-isodate \
11 ${PYTHON_PN}-pyparsing \
12 ${PYTHON_PN}-logging \
13 ${PYTHON_PN}-numbers \
14 ${PYTHON_PN}-xml \
15"
16
17BBCLASSEXTEND = "native nativesdk"