summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyhamcrest_2.0.4.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2022-08-12 16:27:51 +0300
committerKhem Raj <raj.khem@gmail.com>2022-08-13 07:05:31 -0700
commit42a1c085e692c3641881b84f1ae984534bca62aa (patch)
tree3b3a8e4104311699e58b767b2b8b2675cf281419 /meta-python/recipes-devtools/python/python3-pyhamcrest_2.0.4.bb
parent5efa61083ad3452667bbf3e5b2a1e2eb8d8cc8ea (diff)
downloadmeta-openembedded-42a1c085e692c3641881b84f1ae984534bca62aa.tar.gz
python3-pyhamcrest: Upgrade 2.0.3 -> 2.0.4
Upgrade to release 2.0.4: - has_properties now returns Matcher[Any] type, which addresses type checking errors when nested as a matcher. - Added Python 3.11 testing Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyhamcrest_2.0.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyhamcrest_2.0.4.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyhamcrest_2.0.4.bb b/meta-python/recipes-devtools/python/python3-pyhamcrest_2.0.4.bb
new file mode 100644
index 000000000..888278af8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyhamcrest_2.0.4.bb
@@ -0,0 +1,15 @@
1SUMMARY = "Hamcrest framework for matcher objects"
2HOMEPAGE = "https://github.com/hamcrest/PyHamcrest"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=79391bf1501c898472d043f36e960612"
5
6SRC_URI[sha256sum] = "b5d9ce6b977696286cf232ce2adf8969b4d0b045975b0936ac9005e84e67e9c1"
7
8inherit pypi python_setuptools_build_meta
9
10DEPENDS += "${PYTHON_PN}-hatch-vcs-native"
11
12RDEPENDS:${PN} += " \
13 ${PYTHON_PN}-six \
14 ${PYTHON_PN}-numbers \
15"