summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pocketsphinx_5.0.4.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2025-01-24 12:58:39 +0200
committerKhem Raj <raj.khem@gmail.com>2025-01-25 09:28:58 -0800
commit90e1801d4a7b1b6779e77ee940c8c526779e2e82 (patch)
tree266d2a7d803ff742f5bb2ca501468b634336786f /meta-python/recipes-devtools/python/python3-pocketsphinx_5.0.4.bb
parent924b1b1cb11300607067943b06f63679848500b9 (diff)
downloadmeta-openembedded-90e1801d4a7b1b6779e77ee940c8c526779e2e82.tar.gz
python3-pocketsphinx: Upgrade 5.0.3 -> 5.0.4
Upgrade to release 5.0.4: - Fix _pocketsphinx.pyx's set_alignment example - fix: evil version pinning must die.die.die - Fix typos discovered by codespell - GitHub Actions: Add Python 3.13 to the testing - Add a simple language model maker script - Add suggested packages to README.md Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pocketsphinx_5.0.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pocketsphinx_5.0.4.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pocketsphinx_5.0.4.bb b/meta-python/recipes-devtools/python/python3-pocketsphinx_5.0.4.bb
new file mode 100644
index 0000000000..2276ea8571
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pocketsphinx_5.0.4.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Python interface to Pocketsphinx libraries."
2DESCRIPTION = "Pythonsphinx is an Open source large vocabulary, speaker-independent continuous speech recognition engines."
3HOMEPAGE = "https://github.com/cmusphinx/pocketsphinx"
4SECTION = "devel/python"
5LICENSE = "BSD-2-Clause | BSD-3-Clause | MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=c4d720cdc9c6953091f65e8b01524bb4"
7
8SRC_URI += "file://0001-cython-Use-cythyon3-in-cmake-check.patch"
9SRC_URI[sha256sum] = "17d2971e998490def9554b6ba41886708422af5b4ae888723b1b077aab0fe8d4"
10
11inherit cmake pkgconfig pypi python3native cython
12
13DEPENDS += "swig-native python3-scikit-build-native gstreamer1.0 gstreamer1.0-plugins-base"
14
15EXTRA_OECMAKE += "-DBUILD_GSTREAMER=ON"
16
17PACKAGES += "${PN}-models ${MLPREFIX}gstreamer1.0-pocketsphinx"
18
19FILES:${MLPREFIX}gstreamer1.0-pocketsphinx = "${libdir}/gstreamer-1.0/"
20FILES:${PN}-models = "${datadir}/pocketsphinx/model"