summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pefile_2023.2.7.bb
diff options
context:
space:
mode:
authorJun Nie <jun.nie@linaro.org>2023-05-11 22:07:43 +0800
committerKhem Raj <raj.khem@gmail.com>2023-05-11 07:18:59 -0700
commit15eb91e30fdb2a1e7963a6a8993965838d0ea7fb (patch)
tree040c1f821668d8a0ba8877ccbfc03311235fa831 /meta-python/recipes-devtools/python/python3-pefile_2023.2.7.bb
parent92c9e8ab1ed8e0871d139cdbde63c06e2233735d (diff)
downloadmeta-openembedded-15eb91e30fdb2a1e7963a6a8993965838d0ea7fb.tar.gz
python3-pefile: Add initial support
To parse and work with Portable Executable (PE) files Signed-off-by: Jun Nie <jun.nie@linaro.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pefile_2023.2.7.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pefile_2023.2.7.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pefile_2023.2.7.bb b/meta-python/recipes-devtools/python/python3-pefile_2023.2.7.bb
new file mode 100644
index 000000000..580b17413
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pefile_2023.2.7.bb
@@ -0,0 +1,13 @@
1SUMMARY = "Python PE parsing module"
2DESCRIPTION = "A multi-platform Python module to parse and work with Portable Executable (PE) files."
3HOMEPAGE = "https://github.com/erocarrera/pefile"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=38066667888b01d8118ff9cc23da1873"
6
7inherit setuptools3 pypi ptest
8SRC_URI[sha256sum] = "82e6114004b3d6911c77c3953e3838654b04511b8b66e8583db70c65998017dc"
9
10PIP_INSTALL_PACKAGE = "pefile"
11PIP_INSTALL_DIST_PATH = "${S}/dist"
12
13BBCLASSEXTEND = "native nativesdk"