diff options
author | Devon Pringle <devon.pringle@digi.com> | 2021-03-16 15:27:17 +1000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-03-17 12:05:44 -0700 |
commit | a07f3d4591aeba3408e5c606f1239a85bc9597e0 (patch) | |
tree | 935be88415e63f051675c5f79b0da18a086d160b /meta-python/recipes-devtools/python/python3-pastedeploy_2.1.1.bb | |
parent | 4f06104d01563e6623e13ba8a72663f64cdbd760 (diff) | |
download | meta-openembedded-a07f3d4591aeba3408e5c606f1239a85bc9597e0.tar.gz |
python3-pastedeploy: Add recipe
Add release 2.1.1:
- Added setuptools as an explicit dependency. This has always been
required but now that more environments are becoming capable of
operating without it being installed, we now need to ensure it's
available.
- pytest-runner removed, use tox to run tests.
License-Update: Use license file from PyPI tarball.
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pastedeploy_2.1.1.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pastedeploy_2.1.1.bb | 21 |
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pastedeploy_2.1.1.bb b/meta-python/recipes-devtools/python/python3-pastedeploy_2.1.1.bb new file mode 100644 index 000000000..47508e222 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pastedeploy_2.1.1.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | SUMMARY = "Load, configure, and compose WSGI applications and servers" | ||
2 | HOMEPAGE = "https://pylonsproject.org/" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://license.txt;md5=1798f29d55080c60365e6283cb49779c" | ||
5 | |||
6 | inherit pypi | ||
7 | PYPI_PACKAGE = "PasteDeploy" | ||
8 | |||
9 | SRC_URI[sha256sum] = "6dead6ab9823a85d585ef27f878bc647f787edb9ca8da0716aa9f1261b464817" | ||
10 | |||
11 | S = "${WORKDIR}/PasteDeploy-${PV}" | ||
12 | |||
13 | inherit setuptools3 | ||
14 | |||
15 | # Uncomment this line to enable all the optional features. | ||
16 | #PACKAGECONFIG ?= "paste docs" | ||
17 | PACKAGECONFIG[paste] = ",,,python3-paste" | ||
18 | PACKAGECONFIG[docs] = ",,,python3-sphinx python3-pylons-sphinx-themes" | ||
19 | |||
20 | DEPENDS= "python3 python3-setuptools-scm-native python3-pytest-runner-native" | ||
21 | RDEPENDS_${PN} += "python3-core python3-misc python3-netclient python3-pkgutil python3-setuptools python3-threading python3-core" | ||