summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-paho-mqtt_1.6.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-10-26 14:48:22 +0300
committerKhem Raj <raj.khem@gmail.com>2021-10-28 09:01:25 -0700
commit295e6dd96c398a2220d8fefc3c83ad735c9e92ca (patch)
treec760c8d2b5d1e18c0307fc97e0b86f556ca59138 /meta-python/recipes-devtools/python/python3-paho-mqtt_1.6.1.bb
parenta57273d1fa2eb168e3eea61ba5270f314afe5d5f (diff)
downloadmeta-openembedded-295e6dd96c398a2220d8fefc3c83ad735c9e92ca.tar.gz
python3-paho-mqtt: Upgrade 1.5.1 -> 1.6.1
Upgrade to release 1.6.1: - Fix Python 2.7 compatilibity. - Changed default TLS version to 1.2 instead of 1.0. - Fix incoming MQTT v5 messages with overall property length > 127 bytes being incorrectly decoded. Closes #541. - MQTTMessageInfo.wait_for_publish() and MQTTMessageInfo.is_published() will now raise exceptions if called when the publish call produced an error. - Remove periodic retry checks for outgoing messages with QoS>0. This means that outgoing messages will only be retried on the client reconnecting to the server. They will *not* be retried when the client is still connected. - The `rc` parameter in the `on_disconnect` callback now has meaningful values in the case of an error. - Callbacks can now be applied to client instances using decorators. - PUBACK messages are now sent to the broker only after the on_message callback has returned. - Raise exceptions when attempting to set MQTT v5 properties to forbidden values. - Callbacks can now be updated from within a callback. - Remove _out_packet_mutex and _current_out_packet_mutex and convert the _out_packet queue use to thread safe. - Add basic MQTT v5 support to the subscribe and publish helper functions. - Fix on_disconnect() sometimes calling the MQTT v3.x callback when it should call the MQTT v5 callback. - Big performance improvement when receiving large payloads, particularly for SSL. - Fix connecting with MQTT v5 to a broker that doesn't support MQTT v5. - Removed ancient Mosquitto compatibility class. - Fix exception on calling Client(client_id="", clean_session=False). - Experimental support for Websockets continuation frames. - `Properties.json()` now converts Correlation Data bytes() objects to hex. - Only use the internal sockpair wakeup when running with loop_start() or loop(). This removes problems when running with an external event loop. - Drain all of sockpairR bytes to avoid unnecessary wakeups and possible timeouts. - Add timeout to MQTTMessageInfo:wait_for_publish(). License-Update: Update to EPL-2.0 Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-paho-mqtt_1.6.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-paho-mqtt_1.6.1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-paho-mqtt_1.6.1.bb b/meta-python/recipes-devtools/python/python3-paho-mqtt_1.6.1.bb
new file mode 100644
index 000000000..81a6d0a9c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-paho-mqtt_1.6.1.bb
@@ -0,0 +1,33 @@
1SUMMARY = "MQTT version 3.1/3.1.1 client library"
2LICENSE = "EPL-1.0 | EDL-1.0"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8e5f264c6988aec56808a3a11e77b913 \
4 file://edl-v10;md5=c09f121939f063aeb5235972be8c722c \
5"
6SRCNAME = "paho-mqtt"
7
8inherit pypi setuptools3
9
10SRC_URI[sha256sum] = "2a8291c81623aec00372b5a85558a372c747cbca8e9934dfe218638b8eefc26f"
11
12DEPENDS += "${PYTHON_PN}-pytest-runner-native"
13
14do_install:append() {
15 install -d -m0755 ${D}${datadir}/${BPN}/examples
16 cp --preserve=mode,timestamps -R ${S}/examples/* ${D}${datadir}/${BPN}/examples
17}
18
19PACKAGES =+ "${PN}-examples"
20
21RDEPENDS:${PN}-examples += "${PN} ${PYTHON_PN}-core"
22
23FILES:${PN}-examples = "${datadir}/${BPN}/examples"
24
25RDEPENDS:${PN} = "\
26 ${PYTHON_PN}-io \
27 ${PYTHON_PN}-logging \
28 ${PYTHON_PN}-math \
29 ${PYTHON_PN}-netclient \
30 ${PYTHON_PN}-threading \
31"
32
33BBCLASSEXTEND = "native nativesdk"