summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ninja_1.11.1.1.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2023-12-20 22:07:33 +0000
committerKhem Raj <raj.khem@gmail.com>2023-12-21 08:00:42 -0800
commitd8637f07a28128f42c69e397b1ddd4ca0e053060 (patch)
treebfb9c32a8f67ee5ab05fa59429070b3c6dcd7b72 /meta-python/recipes-devtools/python/python3-ninja_1.11.1.1.bb
parent6ce73e925d47fef98d345f7b5b12e9e70ccbbd54 (diff)
downloadmeta-openembedded-d8637f07a28128f42c69e397b1ddd4ca0e053060.tar.gz
python3-ninja: update to version 1.11.1.1
Changelog fix(wheels): link libstdc++ statically on manylinux1 by @mayeut in #159 chore(wheels): link libstdc++/libgcc statically on musllinux by @mayeut in #160 chore: add Windows ARM support by @henryiii in #169 chore: continue testing with python 2.7 by @mayeut in #199 chore: move to setuptools_scm by @henryiii in #170 chore: switch to ruff by @henryiii in #174 chore: use trusted publisher deployment by @jcfr in #191 chore: use wheel tags cli by @mayeut in #84 ci: allow setting a version by @henryiii in #171 ci: cancel on repeated pushes by @henryiii in #177 Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ninja_1.11.1.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ninja_1.11.1.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ninja_1.11.1.1.bb b/meta-python/recipes-devtools/python/python3-ninja_1.11.1.1.bb
new file mode 100644
index 000000000..a9e0ed208
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ninja_1.11.1.1.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Ninja is a small build system with a focus on speed"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE_Apache_20;md5=19cbd64715b51267a47bf3750cc6a8a5"
4
5PYPI_PACKAGE = "ninja"
6PYPI_ARCHIVE_NAME_PREFIX = "pypi-"
7
8inherit pypi python_setuptools_build_meta
9SRC_URI[sha256sum] = "9d793b08dd857e38d0b6ffe9e6b7145d7c485a42dcfea04905ca0cdb6017cc3c"
10
11SRC_URI += "file://no-scikit-build.patch \
12 file://run-ninja-from-path.patch"
13
14DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
15
16do_install:append () {
17 rm -rf ${D}${bindir}
18}
19
20RDEPENDS:${PN} = " \
21 ninja \
22 python3-io \
23 python3-json \
24 python3-ninja-syntax \
25"
26
27BBCLASSEXTEND = "native nativesdk"