summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-mypy_1.8.0.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2023-12-21 22:43:59 +0000
committerKhem Raj <raj.khem@gmail.com>2023-12-22 06:39:35 -0800
commitfbf6d4ee53212a36d832fa2361ea1d4e58d0be6e (patch)
tree42d39f999283942fb97b17162e4cd8c080d2c3c5 /meta-python/recipes-devtools/python/python3-mypy_1.8.0.bb
parent82153598816fd56e9a2040ec027ba3ab5bb54d32 (diff)
downloadmeta-openembedded-fbf6d4ee53212a36d832fa2361ea1d4e58d0be6e.tar.gz
python3-mypy: update to version 1.8.0
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-mypy_1.8.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-mypy_1.8.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-mypy_1.8.0.bb b/meta-python/recipes-devtools/python/python3-mypy_1.8.0.bb
new file mode 100644
index 000000000..2e6c7cc07
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-mypy_1.8.0.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Optional static typing for Python 3 and 2 (PEP 484)"
2HOMEPAGE = "https://github.com/python/mypy"
3LICENSE = "MIT & Python-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=8d62fd8f8648cb018e52857347e340b9"
5
6inherit pypi python_setuptools_build_meta
7
8SRC_URI[sha256sum] = "6ff8b244d7085a0b425b56d327b480c3b29cafbd2eff27316a004f9a7391ae07"
9
10BBCLASSEXTEND = "native"
11
12DEPENDS += " \
13 python3-mypy-extensions-native \
14 python3-types-psutil-native \
15 python3-types-setuptools-native \
16 python3-typing-extensions-native \
17"
18
19RDEPENDS:${PN} += " \
20 python3-modules \
21 python3-mypy-extensions \
22 python3-typing-extensions \
23"