summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-m2crypto_0.38.0.bb
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@fujitsu.com>2021-07-05 09:55:53 +0800
committerKhem Raj <raj.khem@gmail.com>2021-07-06 09:40:42 -0700
commiteb7030939983dc4fc5dfb29e4f0ef4e4b4d3f505 (patch)
treed91b9654b588215602e241f068311df28682bedb /meta-python/recipes-devtools/python/python3-m2crypto_0.38.0.bb
parentf7f1c9fb2d63ae4f5e06e91355295a17016b7502 (diff)
downloadmeta-openembedded-eb7030939983dc4fc5dfb29e4f0ef4e4b4d3f505.tar.gz
python3-m2crypto: upgrade 0.37.1 -> 0.38.0
0.38.0 - 2021-06-14 ------------------- - Remove the last use of setup.py test idiom. - Use m2_PyObject_AsReadBuffer instead of PyObject_AsReadBuffer. - Add support for arm64 big endian <Steev Klimaszewski> - Make support of RSA_SSLV23_PADDING optional (it has been deprecated). - Move project to src/ layout - Allow verify_cb_* to be called with ok=True <Casey Deccio> - Be prepared if any of constants in x509_vfy.h is not available. - But we do support 3.8 - We DO NOT support Python 2.6. Refresh the following patch: cross-compile-platform.patch 0001-Allow-verify_cb_-to-be-called-with-ok-True.patch 0001-Use-of-RSA_SSLV23_PADDING-has-been-deprecated.patch Removed since these are included in 0.38.0 Signed-off-by: Zang Ruochen <zangrc.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-m2crypto_0.38.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-m2crypto_0.38.0.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-m2crypto_0.38.0.bb b/meta-python/recipes-devtools/python/python3-m2crypto_0.38.0.bb
new file mode 100644
index 000000000..950de564f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-m2crypto_0.38.0.bb
@@ -0,0 +1,46 @@
1SUMMARY = "A Python crypto and SSL toolkit"
2HOMEPAGE = "https://gitlab.com/m2crypto/m2crypto"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENCE;md5=b0e1f0b7d0ce8a62c18b1287b991800e"
6
7FILESEXTRAPATHS_prepend := "${THISDIR}/python-m2crypto:"
8
9SRC_URI += "file://0001-setup.py-link-in-sysroot-not-in-host-directories.patch \
10 file://cross-compile-platform.patch \
11 file://avoid-host-contamination.patch \
12 "
13SRC_URI[sha256sum] = "99f2260a30901c949a8dc6d5f82cd5312ffb8abc92e76633baf231bbbcb2decb"
14
15PYPI_PACKAGE = "M2Crypto"
16inherit pypi siteinfo setuptools3
17
18DEPENDS += "openssl swig-native"
19RDEPENDS_${PN} += "\
20 ${PYTHON_PN}-datetime \
21 ${PYTHON_PN}-distutils \
22 ${PYTHON_PN}-logging \
23 ${PYTHON_PN}-netclient \
24 ${PYTHON_PN}-netserver \
25 ${PYTHON_PN}-numbers \
26 ${PYTHON_PN}-smtpd \
27 ${PYTHON_PN}-xmlrpc \
28"
29
30DISTUTILS_BUILD_ARGS += "build_ext --openssl=${STAGING_EXECPREFIXDIR} -I${STAGING_INCDIR}"
31DISTUTILS_INSTALL_ARGS += "build_ext --openssl=${STAGING_EXECPREFIXDIR}"
32
33SWIG_FEATURES_x86 = "-D__i386__"
34SWIG_FEATURES_x32 = "-D__ILP32__"
35
36SWIG_FEATURES ?= "-D__${HOST_ARCH}__ ${@['-D__ILP32__','-D__LP64__'][d.getVar('SITEINFO_BITS') != '32']}"
37
38SWIG_FEATURES_append_riscv64 = " -D__SIZEOF_POINTER__=${SITEINFO_BITS}/8 -D__riscv_xlen=${SITEINFO_BITS}"
39SWIG_FEATURES_append_riscv32 = " -D__SIZEOF_POINTER__=${SITEINFO_BITS}/8 -D__riscv_xlen=${SITEINFO_BITS}"
40SWIG_FEATURES_append_mipsarch = " -D_MIPS_SZPTR=${SITEINFO_BITS}"
41SWIG_FEATURES_append_powerpc64le = " -D__powerpc64__"
42export SWIG_FEATURES
43
44export STAGING_DIR
45
46BBCLASSEXTEND = "native"