summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-langtable_0.0.38.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-12-26 10:45:40 -0500
committerArmin Kuster <akuster808@gmail.com>2017-12-30 12:33:19 -0800
commitbc8e40e7abc21aa920414a7056e410c0bb2438c6 (patch)
tree2c81195ee96ff78590cb743a04dcc66613388446 /meta-python/recipes-devtools/python/python3-langtable_0.0.38.bb
parentaadf68393b964fbe26df8f8b6677107e1bcf40ed (diff)
downloadmeta-openembedded-bc8e40e7abc21aa920414a7056e410c0bb2438c6.tar.gz
python3-langtable: update to version 0.0.38
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-langtable_0.0.38.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-langtable_0.0.38.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-langtable_0.0.38.bb b/meta-python/recipes-devtools/python/python3-langtable_0.0.38.bb
new file mode 100644
index 000000000..177a2b529
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-langtable_0.0.38.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "langtable is used to guess reasonable defaults for locale,\
2keyboard, territory"
3HOMEPAGE = "https://github.com/mike-fabian/langtable/"
4LICENSE = "GPLv3+"
5SECTION = "devel/python"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
8
9S = "${WORKDIR}/git"
10B = "${S}"
11
12SRCREV = "35687ca957b746f153a6872139462b1443f8cad1"
13PV = "0.0.38+git${SRCPV}"
14SRC_URI = "git://github.com/mike-fabian/langtable.git;branch=master \
15"
16
17inherit setuptools3 python3native
18
19DISTUTILS_INSTALL_ARGS = "--prefix=${D}/${prefix} \
20 --install-data=${D}/${datadir}/langtable"
21
22FILES_${PN} += "${datadir}/*"
23
24RDEPENDS_${PN} += " \
25 ${PYTHON_PN}-argparse \
26 ${PYTHON_PN}-compression \
27 ${PYTHON_PN}-doctest \
28 ${PYTHON_PN}-enum \
29 ${PYTHON_PN}-logging \
30 ${PYTHON_PN}-signal \
31 ${PYTHON_PN}-xml \
32"