summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-gevent_21.1.2.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-01-28 12:28:59 +0200
committerKhem Raj <raj.khem@gmail.com>2021-02-01 10:43:42 -0800
commitb3d4c2482cb28e4e76b30516e30248aec5015d9f (patch)
tree323a3d1c37abd09de6b932f13ace9709680af3c0 /meta-python/recipes-devtools/python/python3-gevent_21.1.2.bb
parent62a58a0186343de64027f7260d8c76320f8b17bf (diff)
downloadmeta-openembedded-b3d4c2482cb28e4e76b30516e30248aec5015d9f.tar.gz
python3-gevent: Upgrade 20.9.0 -> 21.1.2
- Update the embedded libev from 4.31 to 4.33. - Update the embedded libuv from 1.38.0 to 1.40.0. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-gevent_21.1.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-gevent_21.1.2.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-gevent_21.1.2.bb b/meta-python/recipes-devtools/python/python3-gevent_21.1.2.bb
new file mode 100644
index 000000000..5edd96b34
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-gevent_21.1.2.bb
@@ -0,0 +1,33 @@
1SUMMARY = "A coroutine-based Python networking library"
2DESCRIPTION = "gevent is a coroutine-based Python networking library that uses greenlet to provide \
3a high-level synchronous API on top of the libevent event loop."
4HOMEPAGE = "http://www.gevent.org"
5LICENSE = "MIT & Python-2.0 & BSD"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=4de99aac27b470c29c6c309e0c279b65 \
7 file://NOTICE;md5=18108df3583462cafd457f024b9b09b5 \
8 file://deps/libev/LICENSE;md5=d6ad416afd040c90698edcdf1cbee347 \
9 "
10DEPENDS += "libevent"
11DEPENDS += "${PYTHON_PN}-greenlet"
12RDEPENDS_${PN} = "${PYTHON_PN}-greenlet \
13 ${PYTHON_PN}-mime \
14 ${PYTHON_PN}-pprint \
15 "
16
17FILESEXTRAPATHS_prepend := "${THISDIR}/python-gevent:"
18
19SRC_URI_append = " \
20 file://libev-conf.patch;patch=1;pnum=1 \
21"
22
23SRC_URI[sha256sum] = "520cc2a029a9eef436e4e56b007af7859315cafa21937d43c1d5269f12f2c981"
24
25# The python-gevent has no autoreconf ability
26# and the logic for detecting a cross compile is flawed
27# so always force a cross compile
28do_configure_append() {
29 sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/deps/libev/configure
30 sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/deps/c-ares/configure
31}
32
33inherit pypi setuptools3