summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cython_0.23.1.bb
diff options
context:
space:
mode:
authorDominic Sacré <dominic.sacre@gmx.de>2015-08-24 17:27:54 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-31 19:17:07 +0200
commit29aa76af6579f95340488d2b5ba6fb66f8ea2771 (patch)
treea24149330f15ca206c53b85c8e58604ef1922354 /meta-python/recipes-devtools/python/python3-cython_0.23.1.bb
parentb13250198de5e1a5461e3e8079cf858cc6a084a3 (diff)
downloadmeta-openembedded-29aa76af6579f95340488d2b5ba6fb66f8ea2771.tar.gz
python3-cython: Add new recipe
Use a common .inc file for the python-cython and python3-cython recipes. Add suffix '3' to scripts in ${bindir} to avoid conflict between the two packages. Signed-off-by: Dominic Sacré <dominic.sacre@gmx.de> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cython_0.23.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cython_0.23.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cython_0.23.1.bb b/meta-python/recipes-devtools/python/python3-cython_0.23.1.bb
new file mode 100644
index 000000000..2ce6bdbd6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cython_0.23.1.bb
@@ -0,0 +1,18 @@
1inherit setuptools3
2require python-cython.inc
3
4RDEPENDS_${PN} += "\
5 python3-setuptools \
6"
7
8# running build_ext a second time during install fails, because Python
9# would then attempt to import cythonized modules built for the target
10# architecture.
11DISTUTILS_INSTALL_ARGS += "--skip-build"
12
13do_install_append() {
14 # rename scripts that would conflict with the Python 2 build of Cython
15 mv ${D}${bindir}/cython ${D}${bindir}/cython3
16 mv ${D}${bindir}/cythonize ${D}${bindir}/cythonize3
17 mv ${D}${bindir}/cygdb ${D}${bindir}/cygdb3
18}