summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cryptography_3.3.2.bb
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2021-04-21 10:33:23 +0800
committerKhem Raj <raj.khem@gmail.com>2021-04-21 08:26:07 -0700
commit34f9b39e4be9041186894619e81e8c52dd6c3aef (patch)
tree1691957c5d703f3c7da9686375c6b3428f950434 /meta-python/recipes-devtools/python/python3-cryptography_3.3.2.bb
parenta2ebdf3fe3ecae5b2c8a286d08c55d92d388ef67 (diff)
downloadmeta-openembedded-34f9b39e4be9041186894619e81e8c52dd6c3aef.tar.gz
python3-cryptography: Upgrade to 3.3.2
Fix a security issue CVE-2020-36242 where certain sequences of ``update()`` calls when symmetrically encrypting very large payloads (>2GB) could result in an integer overflow, leading to buffer overflows. Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cryptography_3.3.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cryptography_3.3.2.bb65
1 files changed, 65 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cryptography_3.3.2.bb b/meta-python/recipes-devtools/python/python3-cryptography_3.3.2.bb
new file mode 100644
index 000000000..0a36ffe1b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cryptography_3.3.2.bb
@@ -0,0 +1,65 @@
1SUMMARY = "Provides cryptographic recipes and primitives to python developers"
2HOMEPAGE = "https://cryptography.io/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0 | BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=bf405a8056a6647e7d077b0e7bc36aba"
6
7LDSHARED += "-pthread"
8
9SRC_URI[sha256sum] = "5a60d3780149e13b7a6ff7ad6526b38846354d11a15e21068e57073e29e19bed"
10
11SRC_URI += " \
12 file://run-ptest \
13 file://h-test.patch \
14"
15
16inherit pypi setuptools3
17
18DEPENDS += " \
19 ${PYTHON_PN}-cffi \
20 ${PYTHON_PN}-cffi-native \
21 ${PYTHON_PN}-asn1crypto \
22 ${PYTHON_PN}-six \
23"
24
25RDEPENDS_${PN} += " \
26 ${PYTHON_PN}-cffi \
27 ${PYTHON_PN}-idna \
28 ${PYTHON_PN}-asn1crypto \
29 ${PYTHON_PN}-setuptools \
30 ${PYTHON_PN}-six \
31"
32
33RDEPENDS_${PN}_class-target += " \
34 ${PYTHON_PN}-cffi \
35 ${PYTHON_PN}-idna \
36 ${PYTHON_PN}-numbers \
37 ${PYTHON_PN}-asn1crypto \
38 ${PYTHON_PN}-setuptools \
39 ${PYTHON_PN}-six \
40 ${PYTHON_PN}-threading \
41"
42
43RDEPENDS_${PN}-ptest += " \
44 ${PN} \
45 ${PYTHON_PN}-cryptography-vectors \
46 ${PYTHON_PN}-iso8601 \
47 ${PYTHON_PN}-pretend \
48 ${PYTHON_PN}-pytest \
49 ${PYTHON_PN}-pytz \
50"
51
52inherit ptest
53
54do_install_ptest() {
55 install -d ${D}${PTEST_PATH}/tests
56 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
57 install -d ${D}${PTEST_PATH}/tests/hazmat
58 cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/
59}
60
61FILES_${PN}-dbg += " \
62 ${libdir}/${PYTHON_PN}2.7/site-packages/${SRCNAME}/hazmat/bindings/.debug \
63"
64
65BBCLASSEXTEND = "native nativesdk"