summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-coverage_7.4.1.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2024-01-26 21:28:00 +0000
committerKhem Raj <raj.khem@gmail.com>2024-01-27 09:48:35 -0800
commit7284093cac87d2b3231fee92fbbcd38bf9a45453 (patch)
tree5abf5494542c83d3cd6e95245ec5e8f823ab5b2e /meta-python/recipes-devtools/python/python3-coverage_7.4.1.bb
parent32be2bd921bda2b12bd6a2a3098a18793f2b70b5 (diff)
downloadmeta-openembedded-7284093cac87d2b3231fee92fbbcd38bf9a45453.tar.gz
python3-coverage: update to version 7.4.1
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-coverage_7.4.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-coverage_7.4.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-coverage_7.4.1.bb b/meta-python/recipes-devtools/python/python3-coverage_7.4.1.bb
new file mode 100644
index 000000000..b3da5d571
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-coverage_7.4.1.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Code coverage measurement for Python"
2HOMEPAGE = "https://coverage.readthedocs.io"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2ee41112a44fe7014dce33e26468ba93"
5
6SRC_URI[sha256sum] = "1ed4b95480952b1a26d863e546fa5094564aa0065e1e5f0d4d0041f293251d04"
7
8inherit pypi setuptools3
9
10RDEPENDS:${PN} += " \
11 python3-crypt \
12 python3-io \
13 python3-json \
14 python3-multiprocessing \
15 python3-pprint \
16 python3-shell \
17 python3-sqlite3 \
18 python3-tomllib \
19 python3-xml \
20"
21
22BBCLASSEXTEND = "native nativesdk"