summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-blinker_1.4.bb
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2020-06-30 09:17:29 +0800
committerKhem Raj <raj.khem@gmail.com>2020-07-03 18:07:00 -0700
commit81754bc54fa69265cda2f79ced1a5de616425f16 (patch)
treed2d8a58291da243244a014b8a3b72fc475a37ecd /meta-python/recipes-devtools/python/python3-blinker_1.4.bb
parent19648e72f814feade99afcf971142a4dc047a7ac (diff)
downloadmeta-openembedded-81754bc54fa69265cda2f79ced1a5de616425f16.tar.gz
python3-blinker: Enable ptest
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-blinker_1.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-blinker_1.4.bb16
1 files changed, 15 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-blinker_1.4.bb b/meta-python/recipes-devtools/python/python3-blinker_1.4.bb
index e2f76c33d..18544b900 100644
--- a/meta-python/recipes-devtools/python/python3-blinker_1.4.bb
+++ b/meta-python/recipes-devtools/python/python3-blinker_1.4.bb
@@ -5,4 +5,18 @@ LIC_FILES_CHKSUM = "file://PKG-INFO;md5=946d7e89af6f7733aeaebed5635d2682"
5SRC_URI[md5sum] = "8b3722381f83c2813c52de3016b68d33" 5SRC_URI[md5sum] = "8b3722381f83c2813c52de3016b68d33"
6SRC_URI[sha256sum] = "471aee25f3992bd325afa3772f1063dbdbbca947a041b8b89466dc00d606f8b6" 6SRC_URI[sha256sum] = "471aee25f3992bd325afa3772f1063dbdbbca947a041b8b89466dc00d606f8b6"
7 7
8inherit pypi setuptools3 8inherit pypi setuptools3 ptest
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
14RDEPENDS_${PN}-ptest += " \
15 ${PYTHON_PN}-pytest \
16 ${PYTHON_PN}-nose \
17"
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/tests
21 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}