summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-02-08 16:08:34 +0800
committerKhem Raj <raj.khem@gmail.com>2023-02-08 08:51:44 -0800
commit5df692b1b515fb45e7f0b65659b32420f5d67f02 (patch)
tree0b91ccd7d8e515fcd6760617896e977a8e5f8bd4 /meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb
parent585e4da5ab391c859dc0371f5cc0420e5c823a27 (diff)
downloadmeta-openembedded-5df692b1b515fb45e7f0b65659b32420f5d67f02.tar.gz
python3-aspectlib: upgrade 1.5.2 -> 2.0.0
License-Update: Copyright updated to 2022. 0001-Remove-tornado-6-test-constraint.-Ref-15.patch removed since it's not available in 2.0.0. Changelog: ========= Drop support for legacy Pythons (2.7, 3.6 or older). Remove Travis/Appveyor CI and switch to GitHub Actions. Added support for Tornado 6 (in the test suite). Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb31
1 files changed, 0 insertions, 31 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb b/meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb
deleted file mode 100644
index 71f3d3594..000000000
--- a/meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb
+++ /dev/null
@@ -1,31 +0,0 @@
1# Copyright (C) 2021 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "An aspect-oriented programming, monkey-patch and decorators library."
5DESCRIPTION = " It is useful when changing behavior in existing code is desired. \
6It includes tools for debugging and testing: simple mock/record and a complete capture/replay framework."
7HOMEPAGE = "https://github.com/ionelmc/python-aspectlib"
8LICENSE = "BSD-2-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=d58b3f20fd10347a9458b8a03793b62e"
10
11SRC_URI[sha256sum] = "d275ec82c4c2712e564bb760e4accff8f061f648e38774feabeb8b241cf3a4aa"
12
13inherit ptest pypi setuptools3
14
15SRC_URI += "file://run-ptest \
16 file://0001-Remove-tornado-6-test-constraint.-Ref-15.patch \
17 "
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/tests
21 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}
23
24RDEPENDS:${PN}-ptest += "\
25 python3-tornado \
26 python3-process-tests \
27"
28
29RDEPENDS:${PN} += "python3-core python3-fields"
30
31BBCLASSEXTEND = "native nativesdk"