summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-06-22 20:26:20 -0700
committerKhem Raj <raj.khem@gmail.com>2021-06-24 12:54:18 -0700
commit0b19534f5e1cad8a272978ee8dfe9454220fe158 (patch)
tree8572a4772e73a54f87bdfc7885a33f771331cf8c /meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb
parent13fadb1d03085322d317fdcce22ba5bb22bbe76c (diff)
downloadmeta-openembedded-0b19534f5e1cad8a272978ee8dfe9454220fe158.tar.gz
python3-aspectlib: Add ptests
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb16
1 files changed, 15 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb b/meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb
index 415a43067..2dc57a6bb 100644
--- a/meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb
+++ b/meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb
@@ -8,7 +8,21 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=d58b3f20fd10347a9458b8a03793b62e"
8 8
9SRC_URI[sha256sum] = "d275ec82c4c2712e564bb760e4accff8f061f648e38774feabeb8b241cf3a4aa" 9SRC_URI[sha256sum] = "d275ec82c4c2712e564bb760e4accff8f061f648e38774feabeb8b241cf3a4aa"
10 10
11inherit pypi setuptools3 11inherit ptest pypi setuptools3
12
13SRC_URI += "file://run-ptest \
14 file://0001-Remove-tornado-6-test-constraint.-Ref-15.patch \
15 "
16
17do_install_ptest() {
18 install -d ${D}${PTEST_PATH}/tests
19 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
20}
21
22RDEPENDS_${PN}-ptest += "\
23 python3-tornado \
24 python3-process-tests \
25"
12 26
13RDEPENDS_${PN} += "python3-core python3-fields" 27RDEPENDS_${PN} += "python3-core python3-fields"
14 28