summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pyzmq
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2015-02-13 09:53:53 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2015-02-27 09:35:51 +0100
commitf54a98d4087757813fc1a08d9a8d19a2f5dd9c3a (patch)
treea70025977a2f8dbfb2f25c09c19d9089e722f341 /meta-python/recipes-devtools/python/python-pyzmq
parenta84b65c7d079d6205bd45b32b55231faeea9938b (diff)
downloadmeta-openembedded-f54a98d4087757813fc1a08d9a8d19a2f5dd9c3a.tar.gz
python-pyzmq: Add recipe for Python Zero Message Queue bindings.
Signed-off-by: Philip Balister <philip@balister.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pyzmq')
-rw-r--r--meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch b/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch
new file mode 100644
index 000000000..2dc3b73f9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch
@@ -0,0 +1,26 @@
1diff --git a/setup.py b/setup.py
2index 62df445..1fdbdeb 100755
3--- a/setup.py
4+++ b/setup.py
5@@ -213,12 +213,6 @@ def settings_from_prefix(prefix=None, bundle_libzmq_dylib=False):
6 pass
7 # unused rpath args for OS X:
8 # settings['extra_link_args'] = ['-Wl,-rpath','-Wl,$ORIGIN/..']
9- else:
10- settings['runtime_library_dirs'] += ['$ORIGIN/..']
11- elif sys.platform != 'darwin':
12- settings['runtime_library_dirs'] += [
13- os.path.abspath(x) for x in settings['library_dirs']
14- ]
15
16 return settings
17
18@@ -592,8 +586,6 @@ class Configure(build_ext):
19 pass
20 # unused rpath args for OS X:
21 # settings['extra_link_args'] = ['-Wl,-rpath','-Wl,$ORIGIN/../zmq']
22- else:
23- settings['runtime_library_dirs'] = [ os.path.abspath(pjoin('.', 'zmq')) ]
24
25 line()
26 info("Configure: Autodetecting ZMQ settings...")