summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pyyaml
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-python/recipes-devtools/python/python-pyyaml
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pyyaml')
-rw-r--r--meta-python/recipes-devtools/python/python-pyyaml/setup.py64
1 files changed, 64 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyyaml/setup.py b/meta-python/recipes-devtools/python/python-pyyaml/setup.py
new file mode 100644
index 000000000..fb6498341
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyyaml/setup.py
@@ -0,0 +1,64 @@
1NAME = 'PyYAML'
2VERSION = '3.06'
3DESCRIPTION = "YAML parser and emitter for Python"
4LONG_DESCRIPTION = """\
5YAML is a data serialization format designed for human readability and
6interaction with scripting languages. PyYAML is a YAML parser and
7emitter for Python.
8
9PyYAML features a complete YAML 1.1 parser, Unicode support, pickle
10support, capable extension API, and sensible error messages. PyYAML
11supports standard YAML tags and provides Python-specific tags that allow
12to represent an arbitrary Python object.
13
14PyYAML is applicable for a broad range of tasks from complex
15configuration files to object serialization and persistance."""
16AUTHOR = "Kirill Simonov"
17AUTHOR_EMAIL = 'xi@resolvent.net'
18LICENSE = "MIT"
19PLATFORMS = "Any"
20URL = "http://pyyaml.org/wiki/PyYAML"
21DOWNLOAD_URL = "http://pyyaml.org/download/pyyaml/%s-%s.tar.gz" % (NAME, VERSION)
22CLASSIFIERS = [
23 "Development Status :: 5 - Production/Stable",
24 "Intended Audience :: Developers",
25 "License :: OSI Approved :: MIT License",
26 "Operating System :: OS Independent",
27 "Programming Language :: Python",
28 "Topic :: Software Development :: Libraries :: Python Modules",
29 "Topic :: Text Processing :: Markup",
30]
31
32from distutils.core import setup
33from distutils.extension import Extension
34from Cython.Distutils import build_ext
35
36import sys, os.path
37
38
39if __name__ == '__main__':
40
41 setup(
42 name=NAME,
43 version=VERSION,
44 description=DESCRIPTION,
45 long_description=LONG_DESCRIPTION,
46 author=AUTHOR,
47 author_email=AUTHOR_EMAIL,
48 license=LICENSE,
49 platforms=PLATFORMS,
50 url=URL,
51 download_url=DOWNLOAD_URL,
52 classifiers=CLASSIFIERS,
53
54 package_dir={'': 'lib'},
55 packages=['yaml'],
56
57 ext_modules = [
58 Extension( "_yaml", ["ext/_yaml.pyx"], libraries = ["yaml"] )
59 ],
60
61 cmdclass={
62 'build_ext': build_ext,
63 },
64 )