summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pyopenssl_16.0.0.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-05-21 09:32:30 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-05-27 15:39:12 +0200
commitfaa6511eee2973e5bc3bdb0fc82de75de2d1b79d (patch)
tree0669379714c5339eed1202eb3761a3f71d8b3e63 /meta-python/recipes-devtools/python/python-pyopenssl_16.0.0.bb
parentb1ca6903e9c64325ff0b7e31e7ac00f1c7ad0926 (diff)
downloadmeta-openembedded-faa6511eee2973e5bc3bdb0fc82de75de2d1b79d.tar.gz
python-pyopenssl: update to version 16.0.0
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pyopenssl_16.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-pyopenssl_16.0.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyopenssl_16.0.0.bb b/meta-python/recipes-devtools/python/python-pyopenssl_16.0.0.bb
new file mode 100644
index 000000000..d1d8f63fc
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyopenssl_16.0.0.bb
@@ -0,0 +1,18 @@
1SUMMARY = "Simple Python wrapper around the OpenSSL library"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
4
5DEPENDS = "openssl python-cryptography"
6
7SRC_URI[md5sum] = "9587d813dcf656e9f2760e41a3682dc3"
8SRC_URI[sha256sum] = "363d10ee43d062285facf4e465f4f5163f9f702f9134f0a5896f134cbb92d17d"
9PYPI_PACKAGE_HASH = "77f2bccec75ca4280a9fa762a90a1b8b152a22eac5d9c726d7da1fcbfe0a20e6"
10
11PYPI_PACKAGE = "pyOpenSSL"
12inherit pypi setuptools
13
14PACKAGES =+ "${PN}-tests"
15FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"
16
17RDEPENDS_${PN} = "python-threading python-six python-cryptography"
18RDEPENDS_${PN}-tests = "${PN}"