summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-02-14 23:05:18 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-25 17:45:48 +0100
commit9d9a616a392deeb06bf7458902281c9bfeb7f5b6 (patch)
treedccc15079aa4f39de3266c838415202ada4a4060 /meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb
parentb62ae60f869b83721757a2f5316cdc26c1030af3 (diff)
downloadmeta-openembedded-9d9a616a392deeb06bf7458902281c9bfeb7f5b6.tar.gz
Update python recipes to use the common pypi package
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb11
1 files changed, 2 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb b/meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb
index d80e6667a..5027c6dbc 100644
--- a/meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb
+++ b/meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb
@@ -1,22 +1,15 @@
1SUMMARY = "Simple Python wrapper around the OpenSSL library" 1SUMMARY = "Simple Python wrapper around the OpenSSL library"
2SECTION = "devel/python"
3
4LICENSE = "Apache-2.0" 2LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" 3LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6 4
7SRCNAME = "pyOpenSSL"
8
9DEPENDS = "openssl python-cryptography" 5DEPENDS = "openssl python-cryptography"
10PE = "1" 6PE = "1"
11 7
12SRC_URI = "http://pypi.python.org/packages/source/p/pyOpenSSL/pyOpenSSL-${PV}.tar.gz"
13
14SRC_URI[md5sum] = "f447644afcbd5f0a1f47350fec63a4c6" 8SRC_URI[md5sum] = "f447644afcbd5f0a1f47350fec63a4c6"
15SRC_URI[sha256sum] = "f0a26070d6db0881de8bcc7846934b7c3c930d8f9c79d45883ee48984bc0d672" 9SRC_URI[sha256sum] = "f0a26070d6db0881de8bcc7846934b7c3c930d8f9c79d45883ee48984bc0d672"
16 10
17S = "${WORKDIR}/${SRCNAME}-${PV}" 11PYPI_PACKAGE = "pyOpenSSL"
18 12inherit pypi setuptools
19inherit setuptools
20 13
21PACKAGES =+ "${PN}-tests" 14PACKAGES =+ "${PN}-tests"
22FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test" 15FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"