summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb
diff options
context:
space:
mode:
authorLi xin <lixin.fnst@cn.fujitsu.com>2015-08-07 13:51:42 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-24 13:56:26 +0200
commit82476e6f80ebc6b4fb20fc8fe4326a2403d2da69 (patch)
tree1e6fbb7d7e30e79ab109cd1a87ec5e47f4f28547 /meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb
parent44bd0256d8ded535f3e214327fa7fbcc4b267dbb (diff)
downloadmeta-openembedded-82476e6f80ebc6b4fb20fc8fe4326a2403d2da69.tar.gz
python-pyopenssl: upgrade 0.13 -> 0.15.1
* Dropped x509_revoked_dup.patch,since the original file crl.c does not exist anymore. * Add DEPENDS python-cryptography to aviod build errors: | error: Could not find suitable distribution for Requirement.parse('six>=1.5.2') | ERROR: python setup.py install execution failed. Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb b/meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb
new file mode 100644
index 000000000..694da275e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyopenssl_0.15.1.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Simple Python wrapper around the OpenSSL library"
2SECTION = "devel/python"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7SRCNAME = "pyOpenSSL"
8
9DEPENDS = "openssl python-cryptography"
10PE = "1"
11
12SRC_URI = "http://pypi.python.org/packages/source/p/pyOpenSSL/pyOpenSSL-${PV}.tar.gz"
13
14SRC_URI[md5sum] = "f447644afcbd5f0a1f47350fec63a4c6"
15SRC_URI[sha256sum] = "f0a26070d6db0881de8bcc7846934b7c3c930d8f9c79d45883ee48984bc0d672"
16
17S = "${WORKDIR}/${SRCNAME}-${PV}"
18
19inherit distutils
20
21PACKAGES =+ "${PN}-tests"
22FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"
23
24RDEPENDS_${PN} = "python-threading"
25RDEPENDS_${PN}-tests = "${PN}"