diff options
author | Derek Straka <derek@asterius.io> | 2017-02-22 19:16:19 -0500 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-02-23 23:22:31 +0100 |
commit | 5fd25205ac2546cb3fdc6fb21def108c2f86c0c1 (patch) | |
tree | 12a161363c72d47672b9441b38ea8117ef5f4d29 /meta-python/recipes-devtools/python/python-pylint_1.6.5.bb | |
parent | 903c556674f97e973145f2e06258bcf50a16a2f4 (diff) | |
download | meta-openembedded-5fd25205ac2546cb3fdc6fb21def108c2f86c0c1.tar.gz |
python-pylint: update to version 1.6.5
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pylint_1.6.5.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python-pylint_1.6.5.bb | 44 |
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pylint_1.6.5.bb b/meta-python/recipes-devtools/python/python-pylint_1.6.5.bb new file mode 100644 index 000000000..f5b4ad052 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-pylint_1.6.5.bb | |||
@@ -0,0 +1,44 @@ | |||
1 | SUMMARY="Pylint is a Python source code analyzer" | ||
2 | HOMEPAGE= "http://www.pylint.org/" | ||
3 | LICENSE = "GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4" | ||
5 | |||
6 | SRC_URI[md5sum] = "31da2185bf59142479e4fa16d8a9e347" | ||
7 | SRC_URI[sha256sum] = "a673984a8dd78e4a8b8cfdee5359a1309d833cf38405008f4a249994a8456719" | ||
8 | |||
9 | RDEPENDS_${PN} += "python-codecs \ | ||
10 | python-contextlib \ | ||
11 | python-core \ | ||
12 | python-distutils \ | ||
13 | python-io \ | ||
14 | python-lang \ | ||
15 | python-multiprocessing \ | ||
16 | python-netserver \ | ||
17 | python-numbers \ | ||
18 | python-pickle \ | ||
19 | python-re \ | ||
20 | python-shell \ | ||
21 | python-six \ | ||
22 | python-stringold \ | ||
23 | python-subprocess \ | ||
24 | python-textutils \ | ||
25 | python-unittest \ | ||
26 | python-backports-functools-lru-cache \ | ||
27 | python-setuptools \ | ||
28 | python-astroid \ | ||
29 | python-wrapt \ | ||
30 | python-isort \ | ||
31 | python-lazy-object-proxy \ | ||
32 | " | ||
33 | |||
34 | inherit pypi setuptools | ||
35 | |||
36 | do_install_append(){ | ||
37 | rm ${D}${bindir}/pylint | ||
38 | cat >> ${D}${bindir}/pylint <<EOF | ||
39 | #!/usr/bin/env python | ||
40 | from pylint import run_pylint | ||
41 | run_pylint() | ||
42 | EOF | ||
43 | chmod 755 ${D}${bindir}/pylint | ||
44 | } | ||