summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pygpgme_0.3.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-02-14 23:05:18 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-25 17:45:48 +0100
commit9d9a616a392deeb06bf7458902281c9bfeb7f5b6 (patch)
treedccc15079aa4f39de3266c838415202ada4a4060 /meta-python/recipes-devtools/python/python-pygpgme_0.3.bb
parentb62ae60f869b83721757a2f5316cdc26c1030af3 (diff)
downloadmeta-openembedded-9d9a616a392deeb06bf7458902281c9bfeb7f5b6.tar.gz
Update python recipes to use the common pypi package
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pygpgme_0.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-pygpgme_0.3.bb9
1 files changed, 2 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python-pygpgme_0.3.bb b/meta-python/recipes-devtools/python/python-pygpgme_0.3.bb
index 39a7adaa9..03c47908d 100644
--- a/meta-python/recipes-devtools/python/python-pygpgme_0.3.bb
+++ b/meta-python/recipes-devtools/python/python-pygpgme_0.3.bb
@@ -2,24 +2,19 @@ SUMMARY = "A Python module for working with OpenPGP messages"
2DESCRIPTION = "PyGPGME is a Python module that lets you sign, verify, \ 2DESCRIPTION = "PyGPGME is a Python module that lets you sign, verify, \
3 encrypt and decrypt messages using the OpenPGP format." 3 encrypt and decrypt messages using the OpenPGP format."
4HOMEPAGE = "https://launchpad.net/pygpgme" 4HOMEPAGE = "https://launchpad.net/pygpgme"
5SECTION = "devel/python"
6 5
7LICENSE = "LGPL-2.1" 6LICENSE = "LGPL-2.1"
8LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=6517bdc8f2416f27ab725d4702f7aac3" 7LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=6517bdc8f2416f27ab725d4702f7aac3"
9 8
10SRC_URI = "https://pypi.python.org/packages/source/p/pygpgme/pygpgme-${PV}.tar.gz \ 9SRC_URI = "file://run-ptest"
11 file://run-ptest \
12 "
13 10
14SRC_URI[md5sum] = "d38355af73f0352cde3d410b25f34fd0" 11SRC_URI[md5sum] = "d38355af73f0352cde3d410b25f34fd0"
15SRC_URI[sha256sum] = "5fd887c407015296a8fd3f4b867fe0fcca3179de97ccde90449853a3dfb802e1" 12SRC_URI[sha256sum] = "5fd887c407015296a8fd3f4b867fe0fcca3179de97ccde90449853a3dfb802e1"
16 13
17S = "${WORKDIR}/pygpgme-${PV}"
18
19DEPENDS += "gpgme" 14DEPENDS += "gpgme"
20RDEPENDS_${PN} += "gnupg" 15RDEPENDS_${PN} += "gnupg"
21 16
22inherit setuptools ptest 17inherit pypi setuptools ptest
23 18
24do_install_ptest(){ 19do_install_ptest(){
25 install ${S}/test_all.py ${D}${PTEST_PATH} 20 install ${S}/test_all.py ${D}${PTEST_PATH}