summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pip_7.1.0.bb
diff options
context:
space:
mode:
authorLi xin <lixin.fnst@cn.fujitsu.com>2015-08-07 13:34:49 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-24 13:56:25 +0200
commit44bd0256d8ded535f3e214327fa7fbcc4b267dbb (patch)
treeac268486b30e78d8fef07404e64d39a7f752cba7 /meta-python/recipes-devtools/python/python-pip_7.1.0.bb
parent5bc978bc3a2cd63cf43c418708c375d475360f2d (diff)
downloadmeta-openembedded-44bd0256d8ded535f3e214327fa7fbcc4b267dbb.tar.gz
python-pip: upgrade 1.5.6 -> 7.1.0
Version numbers are now simply "X.Y" where the leading "1" has been dropped. Reference: https://github.com/pypa/pip/blob/develop/CHANGES.txt Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pip_7.1.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-pip_7.1.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pip_7.1.0.bb b/meta-python/recipes-devtools/python/python-pip_7.1.0.bb
new file mode 100644
index 000000000..ae02e86fe
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pip_7.1.0.bb
@@ -0,0 +1,15 @@
1SUMMARY = "PIP is a tool for installing and managing Python packages"
2LICENSE = "MIT & LGPL-2.1"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=45665b53032c02b35e29ddab8e61fa91"
4
5SRC_URI = "https://pypi.python.org/packages/source/p/pip/pip-${PV}.tar.gz"
6
7SRC_URI[md5sum] = "d935ee9146074b1d3f26c5f0acfd120e"
8SRC_URI[sha256sum] = "d5275ba3221182a5dd1b6bcfbfc5ec277fb399dd23226d6fa018048f7e0f10f2"
9
10S = "${WORKDIR}/pip-${PV}"
11
12inherit setuptools
13
14# Since PIP is like CPAN for PERL we need to drag in all python modules to ensure everything works
15RDEPENDS_${PN} = "python-modules python-distribute"