summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-mccabe
diff options
context:
space:
mode:
authormingli.yu@windriver.com <mingli.yu@windriver.com>2016-07-29 17:00:08 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-05 12:16:38 +0200
commit7e4f22517ada29f634970721481f0a7de1f3bffd (patch)
treec04b4efdf010b9b8778c345843f4c51175d63f90 /meta-python/recipes-devtools/python/python-mccabe
parent6cb4eb3e8631e7309ffa8f14339dcdf579d17dfc (diff)
downloadmeta-openembedded-7e4f22517ada29f634970721481f0a7de1f3bffd.tar.gz
python-mccabe: Remove unnecessary setup_requires pytest-runner
* Remove setup_requires pytest-runner as the setup_requires pytest-runner actually is not used for pytest which only in do_compile phase via setup.py build Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-mccabe')
-rw-r--r--meta-python/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch b/meta-python/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch
new file mode 100644
index 000000000..941bed3d7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch
@@ -0,0 +1,33 @@
1From 3484bdfa7adbaebcf8bb8e7d4820f64b12717932 Mon Sep 17 00:00:00 2001
2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Fri, 29 Jul 2016 15:37:18 +0800
4Subject: [PATCH] python-mccabe: remove unnecessary setup_requires
5 pytest-runner
6
7* Remove setup_requires pytest-runner as the
8 setup_requires pytest-runner actually is not
9 used for pytest which only in do_compile phase
10 via setup.py build
11
12Upstream-Status: Pending
13
14Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
15---
16 setup.py | 1 -
17 1 file changed, 1 deletion(-)
18
19diff --git a/setup.py b/setup.py
20index e59903d..bf2aaba 100644
21--- a/setup.py
22+++ b/setup.py
23@@ -33,7 +33,6 @@ setup(
24 license='Expat license',
25 py_modules=['mccabe'],
26 zip_safe=False,
27- setup_requires=['pytest-runner'],
28 tests_require=['pytest'],
29 entry_points={
30 'flake8.extension': [
31--
322.8.1
33