summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-05-24 14:56:54 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-08 14:55:25 +0200
commitf9ce43cdf6639acaa59d6144aabee798970ca3b6 (patch)
tree4cd53cb95eb5e514d834a65cdbdfa1d8739532c8 /meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb
parente5f01cae3885030f8b3c585e62e7dd7f84a278d9 (diff)
downloadmeta-openembedded-f9ce43cdf6639acaa59d6144aabee798970ca3b6.tar.gz
Remove unnecessary exports of HOST_SYS and BUILD_SYS in python-based recipes
They are no longer required to build python software. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb3
1 files changed, 0 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb b/meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb
index 69f71c711..133e66da4 100644
--- a/meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb
+++ b/meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb
@@ -19,15 +19,12 @@ EXTRA_OECONF = "--disable-docs --with-python-includes=${STAGING_INCDIR}/../"
19inherit distutils 19inherit distutils
20 20
21do_compile_prepend() { 21do_compile_prepend() {
22 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
23 ${STAGING_BINDIR_NATIVE}/python setup.py build ${DISTUTILS_BUILD_ARGS} || \ 22 ${STAGING_BINDIR_NATIVE}/python setup.py build ${DISTUTILS_BUILD_ARGS} || \
24 true 23 true
25} 24}
26 25
27# need to export these variables for python-config to work 26# need to export these variables for python-config to work
28export PYTHONPATH 27export PYTHONPATH
29export BUILD_SYS
30export HOST_SYS
31export STAGING_INCDIR 28export STAGING_INCDIR
32export STAGING_LIBDIR 29export STAGING_LIBDIR
33 30