summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-matplotlib/fix_setup.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-09-01 15:27:20 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-07 10:57:37 +0200
commit10c8c39c25d902ab5268fa48ac2bc0e42e65b179 (patch)
tree26d4745bdeebd5a1734885d777f28b23f6e33713 /meta-python/recipes-devtools/python/python-matplotlib/fix_setup.patch
parent59cbb1d54d62a3a078a126e05310bb1cfa28922a (diff)
downloadmeta-openembedded-10c8c39c25d902ab5268fa48ac2bc0e42e65b179.tar.gz
python-matplotlib: Upgrade to 2.0.2
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-matplotlib/fix_setup.patch')
-rw-r--r--meta-python/recipes-devtools/python/python-matplotlib/fix_setup.patch29
1 files changed, 0 insertions, 29 deletions
diff --git a/meta-python/recipes-devtools/python/python-matplotlib/fix_setup.patch b/meta-python/recipes-devtools/python/python-matplotlib/fix_setup.patch
deleted file mode 100644
index 938158353..000000000
--- a/meta-python/recipes-devtools/python/python-matplotlib/fix_setup.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1This fixes the dependency checks inside of setup.py since things like
2'import numpy' won't work with bitbake.
3
4diff --git a/setup.py b/setup.py
5index 2f13821..e6d6ed0 100644
6--- a/setup.py
7+++ b/setup.py
8@@ -113,12 +113,6 @@ if 1:
9 baseline_images = [chop_package(f) for f in baseline_images]
10 package_data['matplotlib'].extend(baseline_images)
11
12-if not check_for_numpy():
13- sys.exit(1)
14-
15-if not check_for_freetype():
16- sys.exit(1)
17-
18 build_ft2font(ext_modules, packages)
19 build_ttconv(ext_modules, packages)
20 build_contour(ext_modules, packages)
21@@ -129,7 +123,7 @@ build_tri(ext_modules, packages)
22
23 print_raw("")
24 print_raw("OPTIONAL BACKEND DEPENDENCIES")
25-has_libpng = check_for_libpng()
26+has_libpng = True
27
28 if has_libpng and options['build_agg']:
29 build_agg(ext_modules, packages)