summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-m2crypto
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2016-03-06 14:56:42 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-03-14 12:15:23 +0100
commit08b0d3967ec5c2a5427ebdd19fee42ebbe20bec5 (patch)
treef23730a5c9126fe9d99b14285ee3a9bff25886a3 /meta-python/recipes-devtools/python/python-m2crypto
parent7c43e026b1151e3c468fe8432dc1c35cd0122421 (diff)
downloadmeta-openembedded-08b0d3967ec5c2a5427ebdd19fee42ebbe20bec5.tar.gz
python-m2crypt: update package to 0.23.0
this happens to fix the cdra build issue related to the openssl 1.0.2g update. Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-m2crypto')
-rw-r--r--meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch35
1 files changed, 16 insertions, 19 deletions
diff --git a/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch b/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
index bcbdf24bb..819c8e569 100644
--- a/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
+++ b/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
@@ -10,30 +10,27 @@ Upstream-status: Unknown
10 setup.py | 6 +++--- 10 setup.py | 6 +++---
11 1 file changed, 3 insertions(+), 3 deletions(-) 11 1 file changed, 3 insertions(+), 3 deletions(-)
12 12
13diff --git a/setup.py b/setup.py 13Index: M2Crypto-0.23.0/setup.py
14index e7c49eb..8deaa34 100644 14===================================================================
15--- a/setup.py 15--- M2Crypto-0.23.0.orig/setup.py
16+++ b/setup.py 16+++ M2Crypto-0.23.0/setup.py
17@@ -40,7 +40,7 @@ class _M2CryptoBuildExt(build_ext.build_ext): 17@@ -62,7 +62,7 @@ class _M2CryptoBuildExt(build_ext.build_
18 self.openssl = 'c:\\pkg' 18 self.openssl = 'c:\\pkg'
19 else: 19 else:
20 self.libraries = ['ssl', 'crypto'] 20 self.libraries = ['ssl', 'crypto']
21- self.openssl = '/usr' 21- self.openssl = '/usr'
22+ self.openssl = os.environ.get( "STAGING_DIR" ) 22+ self.openssl = os.environ.get( "STAGING_DIR" )
23 23
24
25 def finalize_options(self): 24 def finalize_options(self):
26@@ -49,8 +49,8 @@ class _M2CryptoBuildExt(build_ext.build_ext): 25 '''Overloaded build_ext implementation to append custom openssl
26@@ -75,8 +75,8 @@ class _M2CryptoBuildExt(build_ext.build_
27 if _openssl and os.path.isdir(_openssl):
28 self.openssl = _openssl
27 29
28 build_ext.build_ext.finalize_options(self) 30- self.include_dirs.append(os.path.join(self.openssl, 'include'))
31- openssl_library_dir = os.path.join(self.openssl, 'lib')
32+ self.include_dirs.append(os.environ.get( "STAGING_INCDIR" ))
33+ openssl_library_dir = os.environ.get( "STAGING_LIBDIR" )
29 34
30- opensslIncludeDir = os.path.join(self.openssl, 'include') 35 if platform.system() == "Linux":
31- opensslLibraryDir = os.path.join(self.openssl, 'lib') 36 if _multiarch: # on Fedora/RHEL it is an empty string
32+ opensslIncludeDir = os.environ.get( "STAGING_INCDIR" )
33+ opensslLibraryDir = os.environ.get( "STAGING_LIBDIR" )
34
35 self.swig_opts = ['-I%s' % i for i in self.include_dirs + \
36 [opensslIncludeDir]]
37--
381.8.1.4
39