diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-05-01 12:04:27 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-05-03 08:05:21 -0700 |
commit | b8bbcd4dea422be57123d75fbf77db6d33542b06 (patch) | |
tree | 17575e74c76687ac01ecdd69aed7a71614941326 /meta-python/recipes-devtools/python/python-m2crypto.inc | |
parent | 57baca4bc1b681482bc014508d28f7def5949c33 (diff) | |
download | meta-openembedded-b8bbcd4dea422be57123d75fbf77db6d33542b06.tar.gz |
python3-m2crypto: Upgrade to 0.37.1
Unifiy .inc into .bb
Add patches to fix issues with openssl 1.1.x
Remove m2crypto-0.26.4-gcc_macros patch, its no longer needed
Refresh existing patches
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-m2crypto.inc')
-rw-r--r-- | meta-python/recipes-devtools/python/python-m2crypto.inc | 63 |
1 files changed, 0 insertions, 63 deletions
diff --git a/meta-python/recipes-devtools/python/python-m2crypto.inc b/meta-python/recipes-devtools/python/python-m2crypto.inc deleted file mode 100644 index 797a0354b..000000000 --- a/meta-python/recipes-devtools/python/python-m2crypto.inc +++ /dev/null | |||
@@ -1,63 +0,0 @@ | |||
1 | SUMMARY = "A Python crypto and SSL toolkit" | ||
2 | HOMEPAGE = "https://gitlab.com/m2crypto/m2crypto" | ||
3 | |||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENCE;md5=b0e1f0b7d0ce8a62c18b1287b991800e" | ||
6 | |||
7 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-m2crypto:" | ||
8 | |||
9 | SRC_URI += "file://0001-setup.py-link-in-sysroot-not-in-host-directories.patch \ | ||
10 | file://cross-compile-platform.patch \ | ||
11 | file://m2crypto-0.26.4-gcc_macros.patch \ | ||
12 | " | ||
13 | SRC_URI[md5sum] = "7fce3cbf85eb84a669682892b935746b" | ||
14 | SRC_URI[sha256sum] = "a1b2751cdadc6afac3df8a5799676b7b7c67a6ad144bb62d38563062e7cd3fc6" | ||
15 | |||
16 | PYPI_PACKAGE = "M2Crypto" | ||
17 | inherit pypi siteinfo | ||
18 | |||
19 | DEPENDS += "openssl swig-native" | ||
20 | RDEPENDS_${PN} += "\ | ||
21 | ${PYTHON_PN}-datetime \ | ||
22 | ${PYTHON_PN}-distutils \ | ||
23 | ${PYTHON_PN}-logging \ | ||
24 | ${PYTHON_PN}-netclient \ | ||
25 | ${PYTHON_PN}-netserver \ | ||
26 | ${PYTHON_PN}-numbers \ | ||
27 | ${PYTHON_PN}-smtpd \ | ||
28 | ${PYTHON_PN}-xmlrpc \ | ||
29 | " | ||
30 | |||
31 | DISTUTILS_BUILD_ARGS += "build_ext --openssl=${STAGING_EXECPREFIXDIR} -I${STAGING_INCDIR}" | ||
32 | DISTUTILS_INSTALL_ARGS += "build_ext --openssl=${STAGING_EXECPREFIXDIR}" | ||
33 | |||
34 | SWIG_FEATURES_x86 = "-D__i386__" | ||
35 | SWIG_FEATURES_x32 = "-D__ILP32__" | ||
36 | SWIG_FEATURES ?= "-D__${HOST_ARCH}__" | ||
37 | export SWIG_FEATURES | ||
38 | |||
39 | # Get around a problem with swig, but only if the | ||
40 | # multilib header file exists. | ||
41 | # | ||
42 | do_configure_prepend() { | ||
43 | ${CPP} -dM - < /dev/null | grep -v '__\(STDC\|REGISTER_PREFIX\|GNUC\|STDC_HOSTED\)__' \ | ||
44 | | sed 's/^\(#define \([^ ]*\) .*\)$/#undef \2\n\1/' > ${S}/SWIG/gcc_macros.h | ||
45 | |||
46 | if [ "${SITEINFO_BITS}" = "64" ];then | ||
47 | bit="64" | ||
48 | else | ||
49 | bit="32" | ||
50 | fi | ||
51 | |||
52 | if [ -e ${STAGING_INCDIR}/openssl/opensslconf-${bit}.h ] ;then | ||
53 | for i in SWIG/_ec.i SWIG/_evp.i; do | ||
54 | sed -i -e "s/opensslconf.*\./opensslconf-${bit}\./" "${S}/$i" | ||
55 | done | ||
56 | elif [ -e ${STAGING_INCDIR}/openssl/opensslconf-n${bit}.h ] ;then | ||
57 | for i in SWIG/_ec.i SWIG/_evp.i; do | ||
58 | sed -i -e "s/opensslconf.*\./opensslconf-n${bit}\./" "${S}/$i" | ||
59 | done | ||
60 | fi | ||
61 | } | ||
62 | |||
63 | BBCLASSEXTEND = "native" | ||