diff options
author | Jackie Huang <jackie.huang@windriver.com> | 2014-08-22 02:46:22 -0400 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-08-27 12:48:45 +0200 |
commit | fea3840ee5829afc4b159c81341366e47e4d6959 (patch) | |
tree | 2e63487cb92d4f8fad4397ebec917d527f00e328 /meta-python/recipes-devtools/python/python-cython_0.20.2.bb | |
parent | 196f1050f1c883f5f09763b1797336a9f9300db4 (diff) | |
download | meta-openembedded-fea3840ee5829afc4b159c81341366e47e4d6959.tar.gz |
python-cython: add RDEPENDS on some required python modules
python-distribute:
File "/usr/bin/cython", line 5, in <module>
ImportError: No module named pkg_resources
python-netserver:
File "_tempita.py", line 34, in init Cython.Tempita._tempita
ImportError: No module named cgi
python-subprocess:
File "/usr/lib/python2.7/site-packages/Cython/Debugger/Cygdb.py", line 19, in <module>
ImportError: No module named subprocess
python-shell:
File "/usr/lib/python2.7/site-packages/Cython/Debugger/Cygdb.py", line 16, in <module>
ImportError: No module named glob
Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-cython_0.20.2.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python-cython_0.20.2.bb | 8 |
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-cython_0.20.2.bb b/meta-python/recipes-devtools/python/python-cython_0.20.2.bb index 9f357ec04..3966e0b96 100644 --- a/meta-python/recipes-devtools/python/python-cython_0.20.2.bb +++ b/meta-python/recipes-devtools/python/python-cython_0.20.2.bb | |||
@@ -14,3 +14,11 @@ SRC_URI[md5sum] = "7fc13e1c665bdf7cea19ad08906af91f" | |||
14 | SRC_URI[sha256sum] = "ed13b606a2aeb5bd6c235f8ed6c9988c99d01a033d0d21d56137c13d5c7be63f" | 14 | SRC_URI[sha256sum] = "ed13b606a2aeb5bd6c235f8ed6c9988c99d01a033d0d21d56137c13d5c7be63f" |
15 | 15 | ||
16 | inherit setuptools | 16 | inherit setuptools |
17 | |||
18 | RDEPENDS_${PN} += "\ | ||
19 | python-distribute \ | ||
20 | python-netserver \ | ||
21 | python-subprocess \ | ||
22 | python-shell \ | ||
23 | " | ||
24 | RDEPENDS_${PN}_class-native = "" | ||