diff options
author | Derek Straka <derek@asterius.io> | 2017-12-22 09:16:06 -0500 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2017-12-27 07:25:02 -0800 |
commit | cd7cc6e9dd9f700f07b8a09e6533fa205db28479 (patch) | |
tree | 8f531f529d7a5805fdea89c54a2d26f92be50e73 /meta-python/recipes-devtools/python/python-automat | |
parent | b08b570c8624303acbb6bb064a7bda466a679df4 (diff) | |
download | meta-openembedded-cd7cc6e9dd9f700f07b8a09e6533fa205db28479.tar.gz |
python-automat: fix build dependencies to avoid download during do_compile
Add the correct version of python{3}-setuptools-scm-native
Remove the dependency on m2r
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-automat')
-rw-r--r-- | meta-python/recipes-devtools/python/python-automat/0001-setup.py-remove-the-dependency-on-m2r.patch | 52 |
1 files changed, 52 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-automat/0001-setup.py-remove-the-dependency-on-m2r.patch b/meta-python/recipes-devtools/python/python-automat/0001-setup.py-remove-the-dependency-on-m2r.patch new file mode 100644 index 000000000..0ebb22075 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-automat/0001-setup.py-remove-the-dependency-on-m2r.patch | |||
@@ -0,0 +1,52 @@ | |||
1 | From d5ebe479fc8fe11c5c75e7f35484849320349222 Mon Sep 17 00:00:00 2001 | ||
2 | From: Derek Straka <derek@asterius.io> | ||
3 | Date: Fri, 22 Dec 2017 09:07:00 -0500 | ||
4 | Subject: [PATCH] setup.py: remove the dependency on m2r | ||
5 | |||
6 | The dependency on m2r is removed here as it only provides the | ||
7 | long_description value that is optional. This item is just the | ||
8 | text that would be present on PyPi, so it doesn't provide much | ||
9 | value in this case | ||
10 | |||
11 | Upstream-Status: Inappropriate (OE specific) | ||
12 | |||
13 | Signed-off-by: Derek Straka <derek@asterius.io> | ||
14 | --- | ||
15 | setup.py | 10 ---------- | ||
16 | 1 file changed, 10 deletions(-) | ||
17 | |||
18 | diff --git a/setup.py b/setup.py | ||
19 | index d360c64..7b4180a 100644 | ||
20 | --- a/setup.py | ||
21 | +++ b/setup.py | ||
22 | @@ -4,14 +4,6 @@ Setup file for automat | ||
23 | |||
24 | from setuptools import setup, find_packages | ||
25 | |||
26 | -try: | ||
27 | - from m2r import parse_from_file | ||
28 | - long_description = parse_from_file('README.md') | ||
29 | -except(IOError, ImportError): | ||
30 | - print("\n\n!!! m2r not found, long_description is bad, don't upload this to PyPI !!!\n\n") | ||
31 | - import io | ||
32 | - long_description = io.open('README.md', encoding="utf-8").read() | ||
33 | - | ||
34 | setup( | ||
35 | name='Automat', | ||
36 | use_scm_version=True, | ||
37 | @@ -19,12 +11,10 @@ setup( | ||
38 | description=""" | ||
39 | Self-service finite-state machines for the programmer on the go. | ||
40 | """.strip(), | ||
41 | - long_description=long_description, | ||
42 | packages=find_packages(exclude=[]), | ||
43 | package_dir={'automat': 'automat'}, | ||
44 | setup_requires=[ | ||
45 | 'setuptools-scm', | ||
46 | - 'm2r', | ||
47 | ], | ||
48 | install_requires=[ | ||
49 | "attrs>=16.1.0", | ||
50 | -- | ||
51 | 2.7.4 | ||
52 | |||