summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-autobahn_0.8.6.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-python/recipes-devtools/python/python-autobahn_0.8.6.bb
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-autobahn_0.8.6.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-autobahn_0.8.6.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-autobahn_0.8.6.bb b/meta-python/recipes-devtools/python/python-autobahn_0.8.6.bb
new file mode 100644
index 000000000..ac775c4c3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-autobahn_0.8.6.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "AutobahnPython provides a WebSocket (RFC6455, Hybi-10 to -17, Hixie-76) framework for creating WebSocket-based clients and servers. \
2AutobahnPython also includes an implementation of WAMP (The WebSockets Application Messaging Protocol), a light-weight, \
3asynchronous RPC/PubSub over JSON/WebSocket protocol."
4HOMEPAGE = "http://autobahn.ws/python"
5SECTION = "console/network"
6
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = " file://autobahn/__init__.py;beginline=1;endline=17;md5=1fdeccf6e5b70cda64cc1345597c18e3"
9
10SRC_URI = "https://pypi.python.org/packages/source/a/autobahn/autobahn-${PV}.zip"
11SRC_URI[md5sum] = "160429e7fb043940e79aa7f4ebbab57a"
12SRC_URI[sha256sum] = "94ae5c6f37f9fe7c9d3f12c170fcc273afed4104a1c5508b26d6014bb9e6373e"
13
14S = "${WORKDIR}/autobahn-${PV}"
15
16inherit setuptools
17
18RDEPENDS_${PN} = "python python-pprint python-twisted-protocols python-netserver python-twisted-web"
19