diff options
author | Moritz Fischer <moritz.fischer@ettus.com> | 2017-06-01 09:42:52 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-06-12 06:56:24 +0200 |
commit | 894958c35a8694de53aa3fe63b20a431adaec135 (patch) | |
tree | e995d1b68ddf5c247e73019c8aa66f5f47deae04 /meta-python/recipes-connectivity | |
parent | dff4ea697125cb743b8ac5ae939394a4f05bf6f8 (diff) | |
download | meta-openembedded-894958c35a8694de53aa3fe63b20a431adaec135.tar.gz |
python-mprpc: Add support for python3
Extend recipe to add support for python3
Signed-off-by: Moritz Fischer <moritz.fischer@ettus.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-connectivity')
3 files changed, 21 insertions, 17 deletions
diff --git a/meta-python/recipes-connectivity/python-mprpc/python-mprpc.inc b/meta-python/recipes-connectivity/python-mprpc/python-mprpc.inc new file mode 100644 index 000000000..3a1c0bea1 --- /dev/null +++ b/meta-python/recipes-connectivity/python-mprpc/python-mprpc.inc | |||
@@ -0,0 +1,17 @@ | |||
1 | SUMMARY = "A gevent based messagpack rpc library" | ||
2 | DESCRIPTION = "mprpc is a fast implementation of the messagepack rpc protocol for python. \ | ||
3 | It is based on gevent for handling connections and enabling concurrent connections." | ||
4 | HOMEPAGE = "https://github.com/studio-ousia/mprpc" | ||
5 | LICENSE = "Apache-2.0" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4ba825394aec026b5f94edca44426859" | ||
7 | DEPENDS += "${PYTHON_PN}-gevent" | ||
8 | RDEPENDS_${PN} += "${PYTHON_PN}-gevent ${PYTHON_PN}-msgpack ${PYTHON_PN}-gsocketpool" | ||
9 | |||
10 | SRC_URI_append = " \ | ||
11 | file://0001-fix_setup_py.patch;patch=1;pnum=1 \ | ||
12 | " | ||
13 | |||
14 | SRC_URI[md5sum] = "449e6239eb5ff07b9cceb86e1ab0c2ee" | ||
15 | SRC_URI[sha256sum] = "5881cc7fbb8de814e2b4aa5958bfe147c5c301e46749190f0e6abf373cf56d82" | ||
16 | |||
17 | inherit pypi | ||
diff --git a/meta-python/recipes-connectivity/python-mprpc/python-mprpc_0.1.13.bb b/meta-python/recipes-connectivity/python-mprpc/python-mprpc_0.1.13.bb index 78df00af2..6b2ea2193 100644 --- a/meta-python/recipes-connectivity/python-mprpc/python-mprpc_0.1.13.bb +++ b/meta-python/recipes-connectivity/python-mprpc/python-mprpc_0.1.13.bb | |||
@@ -1,17 +1,2 @@ | |||
1 | SUMMARY = "A gevent based messagpack rpc library" | 1 | require python-mprpc.inc |
2 | DESCRIPTION = "mprpc is a fast implementation of the messagepack rpc protocol for python. \ | 2 | inherit setuptools |
3 | It is based on gevent for handling connections and enabling concurrent connections." | ||
4 | HOMEPAGE = "https://github.com/studio-ousia/mprpc" | ||
5 | LICENSE = "Apache-2.0" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4ba825394aec026b5f94edca44426859" | ||
7 | DEPENDS += "python-gevent" | ||
8 | RDEPENDS_${PN} += "python-gevent python-msgpack python-gsocketpool" | ||
9 | |||
10 | SRC_URI_append = " \ | ||
11 | file://0001-fix_setup_py.patch;patch=1;pnum=1 \ | ||
12 | " | ||
13 | |||
14 | SRC_URI[md5sum] = "449e6239eb5ff07b9cceb86e1ab0c2ee" | ||
15 | SRC_URI[sha256sum] = "5881cc7fbb8de814e2b4aa5958bfe147c5c301e46749190f0e6abf373cf56d82" | ||
16 | |||
17 | inherit pypi setuptools | ||
diff --git a/meta-python/recipes-connectivity/python-mprpc/python3-mprpc_0.1.13.bb b/meta-python/recipes-connectivity/python-mprpc/python3-mprpc_0.1.13.bb new file mode 100644 index 000000000..837d604ed --- /dev/null +++ b/meta-python/recipes-connectivity/python-mprpc/python3-mprpc_0.1.13.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | require python-mprpc.inc | ||
2 | inherit setuptools3 | ||