diff options
author | Dan McGregor <dan.mcgregor@usask.ca> | 2015-11-04 23:05:55 -0600 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-11-06 17:53:58 +0100 |
commit | 4a9921c16e88ca38a6a54e49bc79a58d75b67a9c (patch) | |
tree | 639bac5a774fcd1911b76c702f097cd79c00b3ac /meta-python/recipes-connectivity/gateone | |
parent | 0b895ac766b3e5843a38cc7838368eed53386ab3 (diff) | |
download | meta-openembedded-4a9921c16e88ca38a6a54e49bc79a58d75b67a9c.tar.gz |
gateone: update to latest git
This version works with pyton-tornado 4.2 as currently distributed
with OE.
Signed-off-by: Dan McGregor <dan.mcgregor@usask.ca>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-connectivity/gateone')
-rw-r--r-- | meta-python/recipes-connectivity/gateone/gateone/0001-configuration.py-Hack-around-broken-gethostname-thin.patch | 26 | ||||
-rw-r--r-- | meta-python/recipes-connectivity/gateone/gateone/80oe.conf.in (renamed from meta-python/recipes-connectivity/gateone/gateone/80oe.conf) | 5 | ||||
-rw-r--r-- | meta-python/recipes-connectivity/gateone/gateone/gateone-init.in (renamed from meta-python/recipes-connectivity/gateone/gateone/gateone-init) | 8 | ||||
-rw-r--r-- | meta-python/recipes-connectivity/gateone/gateone/gateone.service | 10 | ||||
-rw-r--r-- | meta-python/recipes-connectivity/gateone/gateone/gateone.service.in | 10 | ||||
-rw-r--r-- | meta-python/recipes-connectivity/gateone/gateone_git.bb | 22 |
6 files changed, 31 insertions, 50 deletions
diff --git a/meta-python/recipes-connectivity/gateone/gateone/0001-configuration.py-Hack-around-broken-gethostname-thin.patch b/meta-python/recipes-connectivity/gateone/gateone/0001-configuration.py-Hack-around-broken-gethostname-thin.patch deleted file mode 100644 index 5f5fa9117..000000000 --- a/meta-python/recipes-connectivity/gateone/gateone/0001-configuration.py-Hack-around-broken-gethostname-thin.patch +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | From d811d3bdf06d78c93c48bef762c19c392c879077 Mon Sep 17 00:00:00 2001 | ||
2 | From: Koen Kooi <koen@dominion.thruhere.net> | ||
3 | Date: Tue, 26 Nov 2013 15:54:10 +0100 | ||
4 | Subject: [PATCH] configuration.py: Hack around broken gethostname thingy | ||
5 | |||
6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
7 | --- | ||
8 | gateone/core/configuration.py | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/gateone/core/configuration.py b/gateone/core/configuration.py | ||
12 | index da41cbd..d1c8222 100644 | ||
13 | --- a/gateone/core/configuration.py | ||
14 | +++ b/gateone/core/configuration.py | ||
15 | @@ -162,7 +162,7 @@ def define_options(installed=True): | ||
16 | ] | ||
17 | # Used both http and https above to demonstrate that both are acceptable | ||
18 | try: | ||
19 | - additional_origins = socket.gethostbyname_ex(socket.gethostname()) | ||
20 | + additional_origins = [] # additional_origins = socket.gethostbyname_ex(socket.gethostname()) | ||
21 | except socket.gaierror: | ||
22 | # Couldn't get any IPs from the hostname | ||
23 | additional_origins = [] | ||
24 | -- | ||
25 | 1.8.4.2 | ||
26 | |||
diff --git a/meta-python/recipes-connectivity/gateone/gateone/80oe.conf b/meta-python/recipes-connectivity/gateone/gateone/80oe.conf.in index cde98bc10..4503da422 100644 --- a/meta-python/recipes-connectivity/gateone/gateone/80oe.conf +++ b/meta-python/recipes-connectivity/gateone/gateone/80oe.conf.in | |||
@@ -2,13 +2,14 @@ | |||
2 | { | 2 | { |
3 | "*": { | 3 | "*": { |
4 | "gateone": { // These settings apply to all of Gate One | 4 | "gateone": { // These settings apply to all of Gate One |
5 | "log_file_prefix": "@localstate@/log/gateone.log", // default would be /var/log/gateone/gateone.log | ||
5 | "log_file_max_size": 5242880, // 5 megabyte logs for OE by default (default would normally be 100Mb) | 6 | "log_file_max_size": 5242880, // 5 megabyte logs for OE by default (default would normally be 100Mb) |
6 | "log_file_num_backups": 2, // Default is normally 10 | 7 | "log_file_num_backups": 2, // Default is normally 10 |
7 | "origins": ["*"], // Every device has a unique origin | 8 | "origins": ["*"], // Every device has a unique origin |
8 | "logging": "info", | 9 | "logging": "info", |
9 | "pid_file": "/var/run/gateone.pid", | 10 | "pid_file": "/run/gateone.pid", |
10 | "session_dir": "/tmp/gateone", | 11 | "session_dir": "/tmp/gateone", |
11 | "user_dir": "/var/lib/gateone/users" | 12 | "user_dir": "@localstate@/lib/gateone/users" |
12 | }, | 13 | }, |
13 | "terminal": { | 14 | "terminal": { |
14 | // Disabling session logging for embedded devices is a good idea (limited/slow storage) | 15 | // Disabling session logging for embedded devices is a good idea (limited/slow storage) |
diff --git a/meta-python/recipes-connectivity/gateone/gateone/gateone-init b/meta-python/recipes-connectivity/gateone/gateone/gateone-init.in index a1cf5ce7e..86d655c94 100644 --- a/meta-python/recipes-connectivity/gateone/gateone/gateone-init +++ b/meta-python/recipes-connectivity/gateone/gateone/gateone-init.in | |||
@@ -11,13 +11,13 @@ | |||
11 | . /etc/init.d/functions | 11 | . /etc/init.d/functions |
12 | 12 | ||
13 | NAME=gateone | 13 | NAME=gateone |
14 | DAEMON=/var/lib/gateone/gateone.py | 14 | DAEMON=@bindir@/gateone |
15 | PIDFILE=/var/run/gateone.pid | 15 | PIDFILE=/run/gateone.pid |
16 | WORKDIR=/var/lib/gateone | 16 | WORKDIR=@localstate@/lib/gateone |
17 | 17 | ||
18 | do_start() { | 18 | do_start() { |
19 | cd $WORKDIR | 19 | cd $WORKDIR |
20 | /usr/bin/python $DAEMON > /dev/null 2>&1 & | 20 | @bindir@/python $DAEMON > /dev/null 2>&1 & |
21 | cd $OLDPWD | 21 | cd $OLDPWD |
22 | } | 22 | } |
23 | 23 | ||
diff --git a/meta-python/recipes-connectivity/gateone/gateone/gateone.service b/meta-python/recipes-connectivity/gateone/gateone/gateone.service deleted file mode 100644 index 7b14d3e6d..000000000 --- a/meta-python/recipes-connectivity/gateone/gateone/gateone.service +++ /dev/null | |||
@@ -1,10 +0,0 @@ | |||
1 | [Unit] | ||
2 | Description=GateOne daemon | ||
3 | ConditionPathExists=|/var/lib/gateone | ||
4 | |||
5 | [Service] | ||
6 | WorkingDirectory=/var/lib/gateone | ||
7 | ExecStart=/usr/bin/python /usr/bin/gateone | ||
8 | |||
9 | [Install] | ||
10 | WantedBy=multi-user.target | ||
diff --git a/meta-python/recipes-connectivity/gateone/gateone/gateone.service.in b/meta-python/recipes-connectivity/gateone/gateone/gateone.service.in new file mode 100644 index 000000000..44667275a --- /dev/null +++ b/meta-python/recipes-connectivity/gateone/gateone/gateone.service.in | |||
@@ -0,0 +1,10 @@ | |||
1 | [Unit] | ||
2 | Description=GateOne daemon | ||
3 | ConditionPathExists=|@localstate@/lib/gateone | ||
4 | |||
5 | [Service] | ||
6 | WorkingDirectory=@localstate@/lib/gateone | ||
7 | ExecStart=@bindir@/python @bindir@/gateone | ||
8 | |||
9 | [Install] | ||
10 | WantedBy=multi-user.target | ||
diff --git a/meta-python/recipes-connectivity/gateone/gateone_git.bb b/meta-python/recipes-connectivity/gateone/gateone_git.bb index 7eae12a8b..5ff753eda 100644 --- a/meta-python/recipes-connectivity/gateone/gateone_git.bb +++ b/meta-python/recipes-connectivity/gateone/gateone_git.bb | |||
@@ -3,14 +3,13 @@ LICENSE = "AGPL-3.0" | |||
3 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=834cbc6995db88433db17cdf8953a428" | 3 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=834cbc6995db88433db17cdf8953a428" |
4 | HOMEPAGE = "http://liftoffsoftware.com/Products/GateOne" | 4 | HOMEPAGE = "http://liftoffsoftware.com/Products/GateOne" |
5 | 5 | ||
6 | PV = "1.2" | 6 | PV = "1.2+git${SRCPV}" |
7 | SRCREV = "1528d324088fc1c180b7fdf50f5b5c1af057eef6" | 7 | SRCREV = "f7a9be46cb90f57459ebd363d24702de0e651034" |
8 | SRC_URI = "git://github.com/liftoff/GateOne.git \ | 8 | SRC_URI = "git://github.com/liftoff/GateOne.git;branch=master \ |
9 | file://0001-configuration.py-Hack-around-broken-gethostname-thin.patch \ | ||
10 | file://gateone-avahi.service \ | 9 | file://gateone-avahi.service \ |
11 | file://80oe.conf \ | 10 | file://80oe.conf.in \ |
12 | file://gateone.service \ | 11 | file://gateone.service.in \ |
13 | file://gateone-init \ | 12 | file://gateone-init.in \ |
14 | " | 13 | " |
15 | 14 | ||
16 | S = "${WORKDIR}/git" | 15 | S = "${WORKDIR}/git" |
@@ -28,7 +27,12 @@ DISTUTILS_INSTALL_ARGS = "--root=${D} \ | |||
28 | do_install_append() { | 27 | do_install_append() { |
29 | 28 | ||
30 | # fix up hardcoded paths | 29 | # fix up hardcoded paths |
31 | sed -i -e s:/usr/bin:${bindir}:g ${WORKDIR}/gateone.service | 30 | for file in gateone.service gateone-init 80oe.conf; do |
31 | sed -e s:@bindir@:${bindir}:g \ | ||
32 | -e s:@localstate@:${localstatedir}:g \ | ||
33 | < ${WORKDIR}/$file.in \ | ||
34 | > ${WORKDIR}/$file | ||
35 | done | ||
32 | 36 | ||
33 | install -d ${D}${systemd_unitdir}/system | 37 | install -d ${D}${systemd_unitdir}/system |
34 | install -m 0644 ${WORKDIR}/gateone.service ${D}${systemd_unitdir}/system | 38 | install -m 0644 ${WORKDIR}/gateone.service ${D}${systemd_unitdir}/system |
@@ -49,6 +53,7 @@ FILES_${PN} = "${localstatedir}/lib ${bindir} ${base_libdir} ${sysconfdir} ${PYT | |||
49 | RDEPENDS_${PN} = "mime-support \ | 53 | RDEPENDS_${PN} = "mime-support \ |
50 | openssh-ssh \ | 54 | openssh-ssh \ |
51 | python-compression \ | 55 | python-compression \ |
56 | python-contextlib \ | ||
52 | python-crypt \ | 57 | python-crypt \ |
53 | python-datetime \ | 58 | python-datetime \ |
54 | python-email \ | 59 | python-email \ |
@@ -76,6 +81,7 @@ RDEPENDS_${PN} = "mime-support \ | |||
76 | python-tornado \ | 81 | python-tornado \ |
77 | python-unixadmin \ | 82 | python-unixadmin \ |
78 | python-xml \ | 83 | python-xml \ |
84 | python-html5lib \ | ||
79 | bash \ | 85 | bash \ |
80 | " | 86 | " |
81 | 87 | ||