summaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2019-06-02 11:43:10 -0700
committerKhem Raj <raj.khem@gmail.com>2019-06-15 16:45:33 -0700
commitc34d38d716707f250af1945a0d65285c1958b2ae (patch)
tree18935c67f5220e426d06b945cfe416d77e933db1 /meta-perl
parent30da5aa95934fae265a8c442ad9568bdedda28a1 (diff)
downloadmeta-openembedded-c34d38d716707f250af1945a0d65285c1958b2ae.tar.gz
libcrypt-openssl-rsa-perl: upgrade 0.30 -> 0.31; enable ptest
* Add runtime and ptest dependencies Upstream release notes: 0.31 Mon Sep 24 2018 - Remove default of SHA256 for RSA keys. This has caused significant problems with downstream modules and it has always been possible to do $key->use_sha256_hash() Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-perl/libcrypt/libcrypt-openssl-rsa-perl_0.30.bb24
-rw-r--r--meta-perl/recipes-perl/libcrypt/libcrypt-openssl-rsa-perl_0.31.bb38
2 files changed, 38 insertions, 24 deletions
diff --git a/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-rsa-perl_0.30.bb b/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-rsa-perl_0.30.bb
deleted file mode 100644
index 0a2ad8aa4..000000000
--- a/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-rsa-perl_0.30.bb
+++ /dev/null
@@ -1,24 +0,0 @@
1SUMMARY = "Crypt Openssl RSA cpan module"
2SECTION = "libs"
3LICENSE = "Artistic-1.0 | GPL-1.0+"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a67ceecc5d9a91a5a0d003ba50c26346"
5
6SRC_URI = "http://www.cpan.org/modules/by-module/Crypt/Crypt-OpenSSL-RSA-${PV}.tar.gz "
7
8SRC_URI[md5sum] = "10bca2fc6d0ba1aa329f227424ae87d5"
9SRC_URI[sha256sum] = "23e13531397af102db4fd24bcf70137add7c85c23cca697c43aa71c2959a29ac"
10
11DEPENDS += "libcrypt-openssl-guess-native openssl"
12
13RDEPENDS_${PN}="libcrypt-openssl-random-perl"
14
15EXTRA_CPANFLAGS = "INC='-I${STAGING_INCDIR}' LIBS='-L${STAGING_LIBDIR} -lssl -L${STAGING_DIR_TARGET}${base_libdir} -lcrypto'"
16
17S = "${WORKDIR}/Crypt-OpenSSL-RSA-${PV}"
18
19inherit cpan
20
21do_compile() {
22 export OTHERLDFLAGS='-Wl,-rpath'
23 cpan_do_compile
24}
diff --git a/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-rsa-perl_0.31.bb b/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-rsa-perl_0.31.bb
new file mode 100644
index 000000000..68d921c3c
--- /dev/null
+++ b/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-rsa-perl_0.31.bb
@@ -0,0 +1,38 @@
1SUMMARY = "Crypt Openssl RSA cpan module"
2SECTION = "libs"
3LICENSE = "Artistic-1.0 | GPL-1.0+"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a67ceecc5d9a91a5a0d003ba50c26346"
5
6SRC_URI = "http://www.cpan.org/modules/by-module/Crypt/Crypt-OpenSSL-RSA-${PV}.tar.gz "
7
8SRC_URI[md5sum] = "d33681e19d2094df7c26bc7a4509265e"
9SRC_URI[sha256sum] = "4173403ad4cf76732192099f833fbfbf3cd8104e0246b3844187ae384d2c5436"
10
11DEPENDS += "libcrypt-openssl-guess-perl-native openssl"
12
13RDEPENDS_${PN} = " \
14 libcrypt-openssl-random-perl \
15 perl-module-autoloader \
16 perl-module-carp \
17 perl-module-strict \
18 perl-module-warnings \
19 perl-module-xsloader \
20"
21
22EXTRA_CPANFLAGS = "INC='-I${STAGING_INCDIR}' LIBS='-L${STAGING_LIBDIR} -lssl -L${STAGING_DIR_TARGET}${base_libdir} -lcrypto'"
23
24S = "${WORKDIR}/Crypt-OpenSSL-RSA-${PV}"
25
26inherit cpan ptest-perl
27
28do_compile() {
29 export OTHERLDFLAGS='-Wl,-rpath'
30 cpan_do_compile
31}
32
33RDEPENDS_${PN}-ptest = " \
34 ${PN} \
35 perl-module-file-copy \
36 perl-module-test \
37 perl-module-test-more \
38"