summaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2019-06-02 11:43:07 -0700
committerKhem Raj <raj.khem@gmail.com>2019-06-15 16:45:33 -0700
commit607bc858c6d9e5c59e676a5f2de17d515c882f83 (patch)
treefb98cf14b7591bd2da331ba15465089d74a5b12a /meta-perl
parent2c5208a9b1ac84c09abde03a0ab5b69237dc1e37 (diff)
downloadmeta-openembedded-607bc858c6d9e5c59e676a5f2de17d515c882f83.tar.gz
libtest-deep-perl: add recipe for v1.128
Test::Deep gives you very flexible ways to check that the result you got is the result you were expecting. At its simplest it compares two structures by going through each level, ensuring that the values match, that arrays and hashes have the same elements and that references are blessed into the correct class. It also handles circular data structures without getting caught in an infinite loop. Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-perl/libtest/libtest-deep-perl_1.128.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libtest/libtest-deep-perl_1.128.bb b/meta-perl/recipes-perl/libtest/libtest-deep-perl_1.128.bb
new file mode 100644
index 000000000..44a915c5b
--- /dev/null
+++ b/meta-perl/recipes-perl/libtest/libtest-deep-perl_1.128.bb
@@ -0,0 +1,56 @@
1SUMMARY = "Test::Deep - Extremely flexible deep comparison"
2DESCRIPTION = "If you don't know anything about automated testing in Perl \
3then you should probably read about Test::Simple and Test::More before \
4preceding. Test::Deep uses the Test::Builder framework. \
5\
6Test::Deep gives you very flexible ways to check that the result you got is \
7the result you were expecting. At its simplest it compares two structures \
8by going through each level, ensuring that the values match, that arrays and \
9hashes have the same elements and that references are blessed into the \
10correct class. It also handles circular data structures without getting \
11caught in an infinite loop. \
12\
13Where it becomes more interesting is in allowing you to do something besides \
14simple exact comparisons. With strings, the \'eq\' operator checks that 2 \
15strings are exactly equal but sometimes that's not what you want. When you \
16don't know exactly what the string should be but you do know some things \
17about how it should look, \'eq\' is no good and you must use pattern matching \
18instead. Test::Deep provides pattern matching for complex data structures \
19distribution."
20
21SECTION = "libs"
22
23HOMEPAGE = "http://github.com/rjbs/Test-Deep/"
24
25LICENSE = "Artistic-1.0 | GPL-1.0+"
26LIC_FILES_CHKSUM = "file://lib/Test/Deep.pm;beginline=1817;endline=1826;md5=aebc793c87a3d8771fe98d5d369898e7"
27
28SRC_URI = "${CPAN_MIRROR}/authors/id/R/RJ/RJBS/Test-Deep-${PV}.tar.gz"
29SRC_URI[md5sum] = "9bc47147ea720fc01bc6b214afb884ff"
30SRC_URI[sha256sum] = "852d7e836fba8269b0b755082051a24a1a309d015a8b76838790af9e3760092f"
31
32UPSTREAM_CHECK_REGEX = "Test\-Deep\-(?P<pver>(\d+\.\d+))(?!_\d+).tar"
33
34S = "${WORKDIR}/Test-Deep-${PV}"
35
36inherit cpan ptest-perl
37
38RDEPENDS_${PN} += " \
39 perl-module-dynaloader \
40 perl-module-exporter \
41 perl-module-fcntl \
42 perl-module-list-util \
43 perl-module-scalar-util \
44 perl-module-strict \
45 perl-module-vars \
46 perl-module-warnings \
47"
48
49RDEPENDS_${PN}-ptest += " \
50 perl-module-if \
51 perl-module-lib \
52 perl-module-test-more \
53 perl-module-test-tester \
54"
55
56BBCLASSEXTEND = "native"