summaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2019-06-27 21:52:17 -0700
committerKhem Raj <raj.khem@gmail.com>2019-07-10 09:24:32 -0700
commit1636d7d9b080fbe57762fb312878d5f2ad71e470 (patch)
tree6311713528d42f45e3791a346781aa6a81409e13 /meta-perl
parent802e23427412f5bce34fbe6ad2c01163056d22b8 (diff)
downloadmeta-openembedded-1636d7d9b080fbe57762fb312878d5f2ad71e470.tar.gz
libencode-perl: upgrade 2.94 -> 3.01; enable ptest
* Clean-up whitespace * Add ptest dependencies License-Update: Only use license lines from META.json Upstream release notes: 3.01 $ $Date: 2019/03/13 00:26:18 $ ! Encode.xs patched: Warning: Use of uninitialized value in subroutine entry https://github.com/dankogai/p5-encode/issues/139#issuecomment-459765852 ! Encode/encode.h Pulled: Fix compile error and warning https://github.com/dankogai/p5-encode/pull/138 3.00 2019/01/31 ! Encode.pm VERSION bumped to 3.00 to make PAUSE happy 2.100 2019/01/31 04:26:40 ! Encode.xs MANIFEST + t/xml.t Pulled: Do not access SV* buffer if we have not called SvPV_force() https://github.com/dankogai/p5-encode/pull/137 ! MANIFEST remove utf8messages.t which is already deleted from the repository. 2.99 2019/01/21 03:13:35 ! Unicode/Unicode.xs Unicode/Unicode.pm VERSION++'ed as Perl core needed. https://github.com/dankogai/p5-encode/issues/136 ! encengine.c Pulled: protect do_encode from NULL dst https://github.com/dankogai/p5-encode/pull/135 2.98 2018/04/22 09:02:00 ! Encode.pm Encode.xs Encode/encode.h Unicode/Unicode.xs encengine.c t/decode.t t/enc_eucjp.t t/utf8messages.t t/utf8warnings.t - t/utf8messages.t + t/utf32warnings.t Pulled: Introduce new Encode check flag Encode::ONLY_PRAGMA_WARNINGS https://github.com/dankogai/p5-encode/pull/134 2.98 2018/04/22 09:02:00 ! t/truncated_utf8.t Resolved: RT125131: truncated_utf8.t TODO test pass in blead https://rt.cpan.org/Ticket/Display.html?id=125131 ! Encode.xs Pulled: Remove XS functions _bytes_to_utf8() and _utf8_to_bytes() https://github.com/dankogai/p5-encode/pull/133 ! Unicode/Unicode.xs Pulled: Automatically compute length in attr() macro https://github.com/dankogai/p5-encode/pull/132 ! Encode.xs Pulled: Fix compile warnings on 64bit MS VS2017 https://github.com/dankogai/p5-encode/pull/131 2.97 2018/02/21 12:14:33 ! Encode.xs Pulled: New perls that fixes https://github.com/dankogai/p5-encode/issues/129 https://rt.cpan.org/Ticket/Display.html?id=124399 https://github.com/dankogai/p5-encode/pull/130 2.96 2018/02/11 05:35:26 ! Encode.pm encoding.pm Unicode/Unicode.pm VERSION++ to make bleadperl happy <CADED=K4v5WQ3R7+aTu1xV4q2RcZFT=jriZubqfrHe7PZrgRmDA@mail.gmail.com> 2.95 2018/02/08 00:26:15 ! Encode.pm Encode.xs Encode/encode.h Unicode/Unicode.pm Unicode/Unicode.xs encengine.c Pulled: new perls https://github.com/dankogai/p5-encode/pull/128 Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-perl/libencode/libencode-perl_2.94.bb68
-rw-r--r--meta-perl/recipes-perl/libencode/libencode-perl_3.01.bb106
2 files changed, 106 insertions, 68 deletions
diff --git a/meta-perl/recipes-perl/libencode/libencode-perl_2.94.bb b/meta-perl/recipes-perl/libencode/libencode-perl_2.94.bb
deleted file mode 100644
index 9861c56e0..000000000
--- a/meta-perl/recipes-perl/libencode/libencode-perl_2.94.bb
+++ /dev/null
@@ -1,68 +0,0 @@
1# NOTE:
2# You should use perl-module-encode rather than this package
3# unless you specifically need a version newer than what is
4# provided by perl.
5
6SUMMARY = "Encode - character encodings"
7DESCRIPTION = "The \"Encode\" module provides the interfaces between \
8Perl's strings and the rest of the system. Perl strings are sequences \
9of characters."
10
11AUTHOR = "Dan Kogai <dankogai+cpan@gmail.com>"
12HOMEPAGE = "https://metacpan.org/release/Encode"
13SECTION = "lib"
14LICENSE = "Artistic-1.0 | GPL-1.0+"
15LIC_FILES_CHKSUM = "file://META.json;md5=d8e909447b983532b2b460c830e7a7e4"
16
17SRC_URI = "${CPAN_MIRROR}/authors/id/D/DA/DANKOGAI/Encode-${PV}.tar.gz"
18SRC_URI[md5sum] = "f995e0eb9e52d01ed57abe835bf3ccb6"
19SRC_URI[sha256sum] = "acb3a4af5e3ee38f94de8baa7454e0b836a0649e7ac4180f28dfca439ad60cff"
20
21UPSTREAM_CHECK_REGEX = "Encode\-(?P<pver>(\d+\.\d+))(?!_\d+).tar"
22
23S = "${WORKDIR}/Encode-${PV}"
24
25inherit cpan
26
27# file /usr/bin/enc2xs from install of perl-misc-5.24.1-r0.i586 conflicts with file from package libencode-perl-2.94-r0.i586
28# file /usr/bin/encguess from install of perl-misc-5.24.1-r0.i586 conflicts with file from package libencode-perl-2.94-r0.i586
29# file /usr/bin/piconv from install of perl-misc-5.24.1-r0.i586 conflicts with file from package libencode-perl-2.94-r0.i586
30RCONFLICTS_${PN} = "perl-misc"
31
32RDEPENDS_${PN} += " perl-module-bytes \
33 perl-module-constant \
34 perl-module-parent \
35 perl-module-storable \
36 perl-module-xsloader \
37"
38
39RPROVIDES_${PN} += "libencode-alias-perl \
40 libencode-byte-perl \
41 libencode-cjkconstants-perl \
42 libencode-cn-perl \
43 libencode-cn-hz-perl \
44 libencode-config-perl \
45 libencode-ebcdic-perl \
46 libencode-encoder-perl \
47 libencode-encoding-perl \
48 libencode-gsm0338-perl \
49 libencode-guess-perl \
50 libencode-jp-perl \
51 libencode-jp-h2z-perl \
52 libencode-jp-jis7-perl \
53 libencode-kr-perl \
54 libencode-kr-2022_kr-perl \
55 libencode-mime-header-perl \
56 libencode-mime-name-perl \
57 libencode-symbol-perl \
58 libencode-tw-perl \
59 libencode-unicode-perl \
60 libencode-unicode-utf7-perl \
61 libencoding-perl \
62 libencode-internal-perl \
63 libencode-mime-header-iso_2022_jp-perl \
64 libencode-utf8-perl \
65 libencode-utf_ebcdic-perl \
66 "
67
68BBCLASSEXTEND = "native"
diff --git a/meta-perl/recipes-perl/libencode/libencode-perl_3.01.bb b/meta-perl/recipes-perl/libencode/libencode-perl_3.01.bb
new file mode 100644
index 000000000..be3a29683
--- /dev/null
+++ b/meta-perl/recipes-perl/libencode/libencode-perl_3.01.bb
@@ -0,0 +1,106 @@
1# NOTE:
2# You should use perl-module-encode rather than this package
3# unless you specifically need a version newer than what is
4# provided by perl.
5
6SUMMARY = "Encode - character encodings"
7DESCRIPTION = "The \"Encode\" module provides the interfaces between \
8Perl's strings and the rest of the system. Perl strings are sequences \
9of characters."
10
11AUTHOR = "Dan Kogai <dankogai+cpan@gmail.com>"
12HOMEPAGE = "https://metacpan.org/release/Encode"
13SECTION = "lib"
14LICENSE = "Artistic-1.0 | GPL-1.0+"
15LIC_FILES_CHKSUM = "file://META.json;beginline=8;endline=10;md5=b12e3be1e17a7e99ca4f429ff32c28b5"
16
17SRC_URI = "${CPAN_MIRROR}/authors/id/D/DA/DANKOGAI/Encode-${PV}.tar.gz"
18SRC_URI[md5sum] = "b0524ca1535ff6956cf1ff696616c94a"
19SRC_URI[sha256sum] = "d4555f570491648dbbd602bce7966672834b4c8f45acaa6757de474fca3a4d87"
20
21UPSTREAM_CHECK_REGEX = "Encode\-(?P<pver>(\d+\.\d+))(?!_\d+).tar"
22
23S = "${WORKDIR}/Encode-${PV}"
24
25inherit cpan ptest-perl
26
27do_install_prepend() {
28 # Requires "-T" (taint) option on command line
29 rm -rf ${B}/t/taint.t
30 # Circular dependency of perl-module-open on perl-module-encode
31 # and we cannot load perl-module-encode because we are providing
32 # an alternative
33 rm -rf ${B}/t/use-Encode-Alias.t
34}
35
36do_install_ptest() {
37 mkdir ${D}${PTEST_PATH}/bin
38 cp -r ${B}/bin/piconv ${D}${PTEST_PATH}/bin
39 cp -r ${B}/blib ${D}${PTEST_PATH}
40 chown -R root:root ${D}${PTEST_PATH}
41}
42
43# file /usr/bin/enc2xs from install of perl-misc-5.24.1-r0.i586 conflicts with file from package libencode-perl-2.94-r0.i586
44# file /usr/bin/encguess from install of perl-misc-5.24.1-r0.i586 conflicts with file from package libencode-perl-2.94-r0.i586
45# file /usr/bin/piconv from install of perl-misc-5.24.1-r0.i586 conflicts with file from package libencode-perl-2.94-r0.i586
46RCONFLICTS_${PN} = "perl-misc perl-module-encode"
47
48RDEPENDS_${PN} += " \
49 perl-module-bytes \
50 perl-module-constant \
51 perl-module-parent \
52 perl-module-storable \
53 perl-module-xsloader \
54 "
55
56RPROVIDES_${PN} += " \
57 libencode-alias-perl \
58 libencode-byte-perl \
59 libencode-cjkconstants-perl \
60 libencode-cn-perl \
61 libencode-cn-hz-perl \
62 libencode-config-perl \
63 libencode-ebcdic-perl \
64 libencode-encoder-perl \
65 libencode-encoding-perl \
66 libencode-gsm0338-perl \
67 libencode-guess-perl \
68 libencode-jp-perl \
69 libencode-jp-h2z-perl \
70 libencode-jp-jis7-perl \
71 libencode-kr-perl \
72 libencode-kr-2022_kr-perl \
73 libencode-mime-header-perl \
74 libencode-mime-name-perl \
75 libencode-symbol-perl \
76 libencode-tw-perl \
77 libencode-unicode-perl \
78 libencode-unicode-utf7-perl \
79 libencoding-perl \
80 libencode-internal-perl \
81 libencode-mime-header-iso_2022_jp-perl \
82 libencode-utf8-perl \
83 libencode-utf_ebcdic-perl \
84 "
85
86RDEPENDS_${PN}-ptest += " \
87 perl-module-blib \
88 perl-module-charnames \
89 perl-module-file-compare \
90 perl-module-file-copy \
91 perl-module-filehandle \
92 perl-module-findbin \
93 perl-module-integer \
94 perl-module-io-select \
95 perl-module-ipc-open3 \
96 perl-module-mime-base64 \
97 perl-module-perlio \
98 perl-module-perlio-encoding \
99 perl-module-perlio-scalar \
100 perl-module-test-more \
101 perl-module-tie-scalar \
102 perl-module-unicore \
103 perl-module-utf8 \
104 "
105
106BBCLASSEXTEND = "native"