summaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2019-06-19 07:59:18 -0700
committerKhem Raj <raj.khem@gmail.com>2019-06-19 10:38:07 -0700
commit0642700df5747bc75191813cda0634d8a3b8decd (patch)
tree21c1db5c0a532429e5c06df04f54f40db212a0c9 /meta-perl
parentfad26cc14e09f901ccf27db4459a4049cb6ad7ed (diff)
downloadmeta-openembedded-0642700df5747bc75191813cda0634d8a3b8decd.tar.gz
libmodule-build-perl: drop, has moved to oe-core
libmodule-build-perl is a dependency for cpan_build.bbclass and as such has been moved to oe-core OE-Core rev: 81ba07d85d21456bf7248b2f04082958e8d724c2 Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-perl/libmodule/libmodule-build-perl_0.4224.bb34
1 files changed, 0 insertions, 34 deletions
diff --git a/meta-perl/recipes-perl/libmodule/libmodule-build-perl_0.4224.bb b/meta-perl/recipes-perl/libmodule/libmodule-build-perl_0.4224.bb
deleted file mode 100644
index d523a7a0c..000000000
--- a/meta-perl/recipes-perl/libmodule/libmodule-build-perl_0.4224.bb
+++ /dev/null
@@ -1,34 +0,0 @@
1SUMMARY = "Module::Build - Build and install Perl modules"
2DESCRIPTION = "Many Perl distributions use a Build.PL file instead of a \
3Makefile.PL file to drive distribution configuration, build, test and \
4installation. Traditionally, Build.PL uses Module::Build as the underlying \
5build system. This module provides a simple, lightweight, drop-in replacement. \
6Whereas Module::Build has over 6,700 lines of code; this module has less than \
7120, yet supports the features needed by most distributions."
8
9SECTION = "libs"
10
11HOMEPAGE = "https://metacpan.org/release/Module-Build"
12
13LICENSE = "Artistic-1.0 | GPL-1.0+"
14LIC_FILES_CHKSUM = "file://README;beginline=960;endline=965;md5=624c06db56a2af4d70cf9edc29fcae1b"
15
16SRC_URI = "${CPAN_MIRROR}/authors/id/L/LE/LEONT/Module-Build-${PV}.tar.gz"
17SRC_URI[md5sum] = "b74c2f6e84b60aad3a3defd30b6f0f4d"
18SRC_URI[sha256sum] = "a6ca15d78244a7b50fdbf27f85c85f4035aa799ce7dd018a0d98b358ef7bc782"
19
20S = "${WORKDIR}/Module-Build-${PV}"
21
22inherit cpan_build
23
24# From:
25# https://github.com/rehsack/meta-cpan/blob/master/recipes-devel/module-build-perl/module-build-perl_0.4216.bb
26#
27do_patch_module_build () {
28 cd ${S}
29 sed -i -e 's,my $interpreter = $self->{properties}{perl};,my $interpreter = "${bindir}/perl";,g' lib/Module/Build/Base.pm
30}
31
32do_patch[postfuncs] += "do_patch_module_build"
33
34BBCLASSEXTEND = "native"