summaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2019-06-27 21:52:25 -0700
committerKhem Raj <raj.khem@gmail.com>2019-07-10 09:24:32 -0700
commit0204452779c8a1240515a03c6f7d776b7f48f1c1 (patch)
tree4c5538b26e512e567faac89e2c5d4bfd4cd17e17 /meta-perl
parent8882acb41a49442da2de6d9eafdf976906173cf6 (diff)
downloadmeta-openembedded-0204452779c8a1240515a03c6f7d776b7f48f1c1.tar.gz
libunicode-linebreak-perl: upgrade 2017.004 -> 2019.001; enable ptest
* Update HOMEPAGE * Use CPAN_MIRROR in SRC_URI * Add to RDEPENDS, not overwrite * Add runtime and ptest dependencies * Add RPROVIDES License-Update: update copyright year; only use lines which apply to license and copyright Upstream release notes: 019.001 Sat Dec 29 ! Makefile.PL - GH PR#4: Added timeout to wget call in Makefile.PL by J. Bargsten. - CPAN RT#125079: Installation stuck after a wget. Fixed by changing scheme from ftp to https. ! lib/Text/LineFold.pm ! t/04fold.t - Fix: Text::LineFold: new() & config() did not allow multiple Prep option ! t/01break.t ! t/02hangul.t ! t/03ns.t ! t/04fold.t ! t/05urgent.t ! t/06context.t ! t/07sea.t ! t/08partial.t ! t/09uri.t ! t/11format.t ! t/12fold2.t ! t/13flowedsp.t ! t/14sea_al.t ! t/15array.t ! t/16regex.t ! t/17prop.t ! t/18currency.t - CPAN RT #120535: Fails tests when no "." in @INC. 2018.012 Sat Dec 29 2018 2018.003 Thu Mar 29 2018 ! Makefile.PL.sombok - CPAN RT#120370: Build fails with recent EUMM and some make variants. Patch by Alexandr Ciornii. Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-perl/libunicode/libunicode-linebreak-perl_2017.004.bb26
-rw-r--r--meta-perl/recipes-perl/libunicode/libunicode-linebreak-perl_2019.001.bb55
2 files changed, 55 insertions, 26 deletions
diff --git a/meta-perl/recipes-perl/libunicode/libunicode-linebreak-perl_2017.004.bb b/meta-perl/recipes-perl/libunicode/libunicode-linebreak-perl_2017.004.bb
deleted file mode 100644
index 5ccb411fa..000000000
--- a/meta-perl/recipes-perl/libunicode/libunicode-linebreak-perl_2017.004.bb
+++ /dev/null
@@ -1,26 +0,0 @@
1SUMMARY = "Unicode::LineBreak - UAX #14 Unicode Line Breaking Algorithm."
2DESCRIPTION = "Unicode::LineBreak performs Line Breaking Algorithm described in Unicode \
3Standard Annex #14 [UAX #14]. East_Asian_Width informative property \
4defined by Annex #11 [UAX #11] will be concerned to determine breaking \
5positions."
6SECTION = "libs"
7
8HOMEPAGE = "http://search.cpan.org/~nezumi/Unicode-LineBreak-${PV}/"
9
10LICENSE = "Artistic-1.0 | GPLv1+"
11LIC_FILES_CHKSUM = "file://README;md5=77241abd74fec561b3f3de1b44c0241b"
12
13SRC_URI = "${CPAN_MIRROR}/authors/id/N/NE/NEZUMI/Unicode-LineBreak-${PV}.tar.gz"
14
15SRC_URI[md5sum] = "de7672227922260ac92d20bbad29660b"
16SRC_URI[sha256sum] = "655bc3c4cb60ad0770d97816716cfe322f24e602c70e595f5941dfa02c40cb76"
17
18S = "${WORKDIR}/Unicode-LineBreak-${PV}"
19
20DEPENDS = "libsombok3 libmime-charset-perl"
21
22RDEPENDS_${PN} = "libsombok3 libmime-charset-perl"
23
24inherit cpan
25
26BBCLASSEXTEND = "native"
diff --git a/meta-perl/recipes-perl/libunicode/libunicode-linebreak-perl_2019.001.bb b/meta-perl/recipes-perl/libunicode/libunicode-linebreak-perl_2019.001.bb
new file mode 100644
index 000000000..304b37577
--- /dev/null
+++ b/meta-perl/recipes-perl/libunicode/libunicode-linebreak-perl_2019.001.bb
@@ -0,0 +1,55 @@
1SUMMARY = "Unicode::LineBreak - UAX #14 Unicode Line Breaking Algorithm."
2DESCRIPTION = "Unicode::LineBreak performs Line Breaking Algorithm described in Unicode \
3Standard Annex #14 [UAX #14]. East_Asian_Width informative property \
4defined by Annex #11 [UAX #11] will be concerned to determine breaking \
5positions."
6SECTION = "libs"
7
8HOMEPAGE = "https://metacpan.org/release/Unicode-LineBreak"
9
10LICENSE = "Artistic-1.0 | GPL-1.0+"
11LIC_FILES_CHKSUM = "file://README;beginline=5;endline=9;md5=b5e8b1099b86b86fbc315b50484231ab"
12
13SRC_URI = "${CPAN_MIRROR}/authors/id/N/NE/NEZUMI/Unicode-LineBreak-${PV}.tar.gz"
14
15SRC_URI[md5sum] = "003d6da7a13700e069afed9238c864b9"
16SRC_URI[sha256sum] = "486762e4cacddcc77b13989f979a029f84630b8175e7fef17989e157d4b6318a"
17
18S = "${WORKDIR}/Unicode-LineBreak-${PV}"
19
20DEPENDS = "libsombok3 libmime-charset-perl"
21
22inherit cpan ptest-perl
23
24do_install_ptest() {
25 cp -r ${B}/test-data ${D}${PTEST_PATH}
26 chown -R root:root ${D}${PTEST_PATH}
27}
28
29RDEPENDS_${PN} += " \
30 libmime-charset-perl \
31 libsombok3 \
32 perl-module-carp \
33 perl-module-constant \
34 perl-module-encode \
35 perl-module-exporter \
36 perl-module-overload \
37 perl-module-strict \
38 perl-module-vars \
39 perl-module-warnings \
40 perl-module-xsloader \
41"
42
43RDEPENDS_${PN}-ptest += " \
44 perl-module-findbin \
45 perl-module-lib \
46 perl-module-strict \
47 perl-module-test-more \
48"
49
50RPROVIDES_${PN} += " \
51 libtext-linefold-perl \
52 libunicode-gcstring-perl \
53"
54
55BBCLASSEXTEND = "native"