diff options
author | Tim Orling <timothy.t.orling@linux.intel.com> | 2019-06-27 21:52:19 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-07-10 09:24:32 -0700 |
commit | aaab97dd105803a36631d0a49875a2c58d39c806 (patch) | |
tree | b518350029208fa4e9ff7066cf2153ce359e9e88 /meta-perl | |
parent | 784285981b1ce9825575981f2b60e2b286251283 (diff) | |
download | meta-openembedded-aaab97dd105803a36631d0a49875a2c58d39c806.tar.gz |
libtest-nowarnings-perl: add recipe for 1.04
* Ensures that no warnings are emitted during tests
* ptest dependency for libdbd-sqlite-perl
Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r-- | meta-perl/recipes-perl/libtest/libtest-nowarnings-perl_1.04.bb | 37 |
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libtest/libtest-nowarnings-perl_1.04.bb b/meta-perl/recipes-perl/libtest/libtest-nowarnings-perl_1.04.bb new file mode 100644 index 000000000..f3c28d39c --- /dev/null +++ b/meta-perl/recipes-perl/libtest/libtest-nowarnings-perl_1.04.bb | |||
@@ -0,0 +1,37 @@ | |||
1 | SUMMARY = "Make sure you didn't emit any warnings while testing" | ||
2 | DESCRIPTION = "In general, your tests shouldn't produce warnings. This \ | ||
3 | modules causes any warnings to be captured and stored. It automatically \ | ||
4 | adds an extra test that will run when your script ends to check that there \ | ||
5 | were no warnings. If there were any warings, the test will give a \\"not ok\\" \ | ||
6 | and diagnostics of where, when and what the warning was, including a stack \ | ||
7 | trace of what was going on when the it occurred.\ | ||
8 | \ | ||
9 | If some of your tests are supposed to produce warnings then you should \ | ||
10 | be capturing and checking them with Test::Warn, that way \ | ||
11 | Test::NoWarnings will not see them and so not complain.\ | ||
12 | \ | ||
13 | The test is run by an \\"END\\" block in Test::NoWarnings. It will not be \ | ||
14 | run when any forked children exit." | ||
15 | |||
16 | SECTION = "libs" | ||
17 | LICENSE = "LGPL-2.1" | ||
18 | |||
19 | HOMEPAGE= "https://metacpan.org/release/Test-NoWarnings" | ||
20 | |||
21 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d8045f3b8f929c1cb29a1e3fd737b499" | ||
22 | |||
23 | CPAN_PACKAGE = "Test-NoWarnings" | ||
24 | CPAN_AUTHOR = "ADAMK" | ||
25 | |||
26 | SRC_URI = "${CPAN_MIRROR}/authors/id/A/AD/${CPAN_AUTHOR}/${CPAN_PACKAGE}-${PV}.tar.gz" | ||
27 | |||
28 | SRC_URI[md5sum] = "682ed043f7d3e38f3dfd8745fd21c49a" | ||
29 | SRC_URI[sha256sum] = "638a57658cb119af1fe5b15e73d47c2544dcfef84af0c6b1b2e97f08202b686c" | ||
30 | |||
31 | RDEPENDS_${PN} += "perl-module-test-builder perl-module-test-more perl-module-test-tester" | ||
32 | |||
33 | S = "${WORKDIR}/${CPAN_PACKAGE}-${PV}" | ||
34 | |||
35 | inherit cpan ptest-perl | ||
36 | |||
37 | BBCLASSEXTEND = "native nativesdk" | ||