summaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2022-10-30 18:44:33 -0700
committerKhem Raj <raj.khem@gmail.com>2022-10-30 23:01:26 -0700
commit74c84f4c1159310e8e1e03d20a57aa4ab009fc9d (patch)
tree7b84e58f061d5923f2de5a40e615e2f7bfa55dd8 /meta-perl
parent0b3e25a3c13f6b896838986899940e0ed986d148 (diff)
downloadmeta-openembedded-74c84f4c1159310e8e1e03d20a57aa4ab009fc9d.tar.gz
libio-compress*-perl: cleanup; fixes
* Fix hardcoded PV in SRC_URI * Use README for LIC_FILES_CHKSUM * Fix HOMEPAGE * Add SUMMARY * Use upstream README for DESCRIPTION * Correct libcompression-*-perl RDEPENDS * Fix RDEPENDS Handy on-target check for dependencies: for path in $(find /usr/lib/perl5/vendor_perl/5.36.0/IO -name *.pm | sed -e 's~/usr/lib/perl5/vendor_perl/5.36.0/~~' -e 's~/~::~g' -e 's~.pm~~'); do perl -M${path} -e'print'; done Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-perl/libio/libio-compress-lzma-perl_2.096.bb23
-rw-r--r--meta-perl/recipes-perl/libio/libio-compress-perl_2.096.bb39
2 files changed, 40 insertions, 22 deletions
diff --git a/meta-perl/recipes-perl/libio/libio-compress-lzma-perl_2.096.bb b/meta-perl/recipes-perl/libio/libio-compress-lzma-perl_2.096.bb
index 15952f17e..09ed161d2 100644
--- a/meta-perl/recipes-perl/libio/libio-compress-lzma-perl_2.096.bb
+++ b/meta-perl/recipes-perl/libio/libio-compress-lzma-perl_2.096.bb
@@ -1,24 +1,25 @@
1DESCRIPTION = "This module provides a Perl interface that allows writing lzma compressed \ 1SUMMARY = "Perl interface to allow reading and writing of lzma files/buffers."
2data to files or buffer." 2DESCRIPTION = "This module provides a Perl interface to allow reading and \
3 3writing of lzma files/buffers."
4HOMEPAGE = "https://metacpan.org/release/IO-Compress-Lzma"
4SECTION = "libs" 5SECTION = "libs"
5LICENSE = "Artistic-1.0 | GPL-1.0-or-later" 6LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
6 7
7MAINTAINER= "Poky <poky@yoctoproject.org>" 8LIC_FILES_CHKSUM = "file://README;beginline=8;endline=10;md5=2d411393b876fe63f9f1d546363f1a47"
8HOMEPAGE= "https://metacpan.org/release/IO-Compress-Lzma"
9
10LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \
11file://${COMMON_LICENSE_DIR}/GPL-1.0-only;md5=e9e36a9de734199567a4d769498f743d"
12 9
13SRC_URI = "https://cpan.metacpan.org/authors/id/P/PM/PMQS/IO-Compress-Lzma-2.096.tar.gz" 10SRC_URI = "${CPAN_MIRROR}/authors/id/P/PM/PMQS/IO-Compress-Lzma-${PV}.tar.gz"
14 11
15SRC_URI[md5sum] = "6c1b70740605b8073e4fbb5ba1e7bbdb" 12SRC_URI[md5sum] = "6c1b70740605b8073e4fbb5ba1e7bbdb"
16SRC_URI[sha256sum] = "2f29125f19bb41d29c4b5a2467e3560b7bce5d428176a046b7c8a51609dce6e8" 13SRC_URI[sha256sum] = "2f29125f19bb41d29c4b5a2467e3560b7bce5d428176a046b7c8a51609dce6e8"
17RDEPENDS:${PN} += "compress-raw-lzma-perl"
18RDEPENDS:${PN} += "libio-compress-perl"
19 14
20S = "${WORKDIR}/IO-Compress-Lzma-${PV}" 15S = "${WORKDIR}/IO-Compress-Lzma-${PV}"
21 16
22inherit cpan 17inherit cpan
23 18
19RDEPENDS:${PN} += "\
20 perl-module-autoloader \
21 libcompress-raw-lzma-perl \
22 libio-compress-perl \
23"
24
24BBCLASSEXTEND = "native" 25BBCLASSEXTEND = "native"
diff --git a/meta-perl/recipes-perl/libio/libio-compress-perl_2.096.bb b/meta-perl/recipes-perl/libio/libio-compress-perl_2.096.bb
index c00d8945b..ea120b824 100644
--- a/meta-perl/recipes-perl/libio/libio-compress-perl_2.096.bb
+++ b/meta-perl/recipes-perl/libio/libio-compress-perl_2.096.bb
@@ -1,24 +1,41 @@
1DESCRIPTION = "This module is not intended for direct use in application code. Its sole \ 1SUMMARY = "Perl interface to allow reading and writing of compressed data."
2purpose is to be sub-classed by IO::Compress modules." 2DESCRIPTION = "This distribution provides a Perl interface to allow reading \
3 3and writing of compressed data created with the zlib and bzip2. \
4\
5IO-Compress supports reading and writing of the following compressed data \
6formats \
7 * bzip2 \
8 * RFC 1950 \
9 * RFC 1951 \
10 * RFC 1952 (i.e. gzip) \
11 * zip \
12"
13HOMEPAGE = "https://metacpan.org/release/IO-Compress"
4SECTION = "libs" 14SECTION = "libs"
5LICENSE = "Artistic-1.0 | GPL-1.0-or-later" 15LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
6 16
7MAINTAINER= "Poky <poky@yoctoproject.org>" 17LIC_FILES_CHKSUM = "file://README;beginline=8;endline=10;md5=36e282c4a4078cf2650d656cdda23210"
8HOMEPAGE= "https://metacpan.org/release/IO-Compress"
9
10LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \
11file://${COMMON_LICENSE_DIR}/GPL-1.0-only;md5=e9e36a9de734199567a4d769498f743d"
12 18
13SRC_URI = "https://cpan.metacpan.org/authors/id/P/PM/PMQS/IO-Compress-2.096.tar.gz" 19SRC_URI = "${CPAN_MIRROR}/authors/id/P/PM/PMQS/IO-Compress-${PV}.tar.gz"
14 20
15SRC_URI[md5sum] = "18ad197cad5ca87bc3a7d2538998e017" 21SRC_URI[md5sum] = "18ad197cad5ca87bc3a7d2538998e017"
16SRC_URI[sha256sum] = "9d219fd5df4b490b5d2f847921e3cb1c3392758fa0bae9b05a8992b3620ba572" 22SRC_URI[sha256sum] = "9d219fd5df4b490b5d2f847921e3cb1c3392758fa0bae9b05a8992b3620ba572"
17RDEPENDS:${PN} += "compress-raw-bzip2-perl"
18RDEPENDS:${PN} += "compress-raw-zlib-perl"
19 23
20S = "${WORKDIR}/IO-Compress-${PV}" 24S = "${WORKDIR}/IO-Compress-${PV}"
21 25
22inherit cpan 26inherit cpan
23 27
28RDEPENDS:${PN} += "\
29 perl-module-bytes \
30 perl-module-cwd \
31 perl-module-encode \
32 perl-module-file-glob \
33 perl-module-file-spec \
34 perl-module-posix \
35 perl-module-scalar-util \
36 perl-module-utf8 \
37 libcompress-raw-bzip2-perl \
38 libcompress-raw-zlib-perl \
39"
40
24BBCLASSEXTEND = "native" 41BBCLASSEXTEND = "native"