diff options
author | Kang Kai <kai.kang@windriver.com> | 2014-08-14 17:13:34 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-08-21 21:35:05 +0200 |
commit | 765436ee81449988125bac0feab19d9ea67a708d (patch) | |
tree | ff38d34c6574b114e18f5a58c285288e3348234e /meta-perl | |
parent | 8e4bee933b2480e6e9dcc0ebad7d6fd0c22165ad (diff) | |
download | meta-openembedded-765436ee81449988125bac0feab19d9ea67a708d.tar.gz |
libio-socket-ssl-perl: add recipe
Add recipe for libio-socket-ssl-perl. Inherit ptest to enable build
-ptest sub-package and add file 'run-ptest'.
Signed-off-by: Kai Kang <kai.kang@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r-- | meta-perl/recipes-perl/libio/files/run-ptest | 16 | ||||
-rw-r--r-- | meta-perl/recipes-perl/libio/libio-socket-ssl-perl_1.997.bb | 45 |
2 files changed, 61 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libio/files/run-ptest b/meta-perl/recipes-perl/libio/files/run-ptest new file mode 100644 index 000000000..c9f9ca94d --- /dev/null +++ b/meta-perl/recipes-perl/libio/files/run-ptest | |||
@@ -0,0 +1,16 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | for case in `find t -type f -name '*.t'`; do | ||
4 | perl $case >$case.output 2>&1 | ||
5 | ret=$? | ||
6 | cat $case.output | ||
7 | if [ $ret -ne 0 ]; then | ||
8 | echo "FAIL: ${case%.t}" | ||
9 | elif grep -i 'SKIP' $case.output; then | ||
10 | echo "SKIP: ${case%.t}" | ||
11 | else | ||
12 | echo "PASS: ${case%.t}" | ||
13 | fi | ||
14 | |||
15 | rm -f $case.output | ||
16 | done | ||
diff --git a/meta-perl/recipes-perl/libio/libio-socket-ssl-perl_1.997.bb b/meta-perl/recipes-perl/libio/libio-socket-ssl-perl_1.997.bb new file mode 100644 index 000000000..19dec83a5 --- /dev/null +++ b/meta-perl/recipes-perl/libio/libio-socket-ssl-perl_1.997.bb | |||
@@ -0,0 +1,45 @@ | |||
1 | SUMMARY = "Perl library for transparent SSL" | ||
2 | DESCRIPTION = "This module is a true drop-in replacement for IO::Socket::INET that \ | ||
3 | uses SSL to encrypt data before it is transferred to a remote server \ | ||
4 | or client. IO::Socket::SSL supports all the extra features that one \ | ||
5 | needs to write a full-featured SSL client or server application: \ | ||
6 | multiple SSL contexts, cipher selection, certificate verification, and \ | ||
7 | SSL version selection. As an extra bonus, it works perfectly with \ | ||
8 | mod_perl." | ||
9 | HOMEPAGE = "http://search.cpan.org/dist/IO-Socket-SSL/" | ||
10 | SECTION = "libs" | ||
11 | |||
12 | LICENSE = "Artistic-1.0|GPLv1+" | ||
13 | LIC_FILES_CHKSUM = "file://META.yml;beginline=11;endline=11;md5=963ce28228347875ace682de56eef8e8" | ||
14 | |||
15 | RDEPENDS_${PN} += "perl-module-scalar-util libnet-ssleay-perl" | ||
16 | |||
17 | SRC_URI = "http://search.cpan.org/CPAN/authors/id/S/SU/SULLR/IO-Socket-SSL-${PV}.tar.gz \ | ||
18 | file://run-ptest \ | ||
19 | " | ||
20 | SRC_URI[md5sum] = "2a6268bb42da81e69d1c1feb2fcb0eea" | ||
21 | SRC_URI[sha256sum] = "acdb67b5b63aea5b7e70c3e4c70a16128810329592b63753a38c794aff76a1dd" | ||
22 | |||
23 | S = "${WORKDIR}/IO-Socket-SSL-${PV}" | ||
24 | |||
25 | inherit cpan ptest | ||
26 | |||
27 | PACKAGE_ARCH = "all" | ||
28 | |||
29 | do_install_append () { | ||
30 | mkdir -p ${D}${docdir}/${PN}/ | ||
31 | cp ${S}/BUGS ${D}${docdir}/${PN}/ | ||
32 | cp ${S}/Changes ${D}${docdir}/${PN}/ | ||
33 | cp ${S}/README ${D}${docdir}/${PN}/ | ||
34 | cp -pRP ${S}/docs ${D}${docdir}/${PN}/ | ||
35 | cp -pRP ${S}/certs ${D}${docdir}/${PN}/ | ||
36 | cp -pRP ${S}/example ${D}${docdir}/${PN}/ | ||
37 | cp -pRP ${S}/util ${D}${docdir}/${PN}/ | ||
38 | } | ||
39 | |||
40 | do_install_ptest () { | ||
41 | cp -r ${B}/t ${D}${PTEST_PATH} | ||
42 | cp -r ${B}/certs ${D}${PTEST_PATH} | ||
43 | } | ||
44 | |||
45 | BBCLASSEXTEND = "native" | ||